PTA 复数类的运算

题目:

根据以下代码段完善 ?? 处内容及程序内容,以实现规定的输出。

class Complex
{
    public:
        Complex(double r=0, double i=0):real(r), imag(i){    }
        Complex operator+( ?? ) const;//重载双目运算符'+'
        Complex operator-=( ?? ); //重载双目运算符'-='
        friend Complex operator-( ?? ) const;//重载双目运算符'-'
        void Display() const;
    private:
        double real;
        double imag;
};

void Complex::Display() const
{
    cout << "(" << real << ", " << imag << ")" << endl;
}

int main()
{
    double r, m;
    cin >> r >> m;
    Complex c1(r, m);
    cin >> r >> m;
    Complex c2(r, m);
    Complex c3 = c1+c2;
    c3.Display();
    c3 = c1-c2;
    c3.Display();
    c3 -= c1;
    c3.Display();
    return 0;
}

输入格式:

输入有两行,分别为两个复数的实部与虚部。

输出格式:

按样例格式输出结果。

输入样例:

在这里给出一组输入。例如:

4 2
3 -5

输出样例:

在这里给出相应的输出。例如:

(7, -3)
(1, 7)
(-3, 5)

 

解题代码: 

#include <iostream>
using namespace std;

class Complex
{
public:
    Complex(double r=0, double i=0):real(r), imag(i){    }
    Complex operator+(Complex c11) const{
        Complex c33;
        c33.real = real + c11.real;
        c33.imag = imag + c11.imag;
        return c33;
    }
    Complex operator-=(Complex c11) {
        real = real - c11.real;
        imag = imag - c11.imag;
        return 0;
    }
    Complex operator-( Complex c11) const{
        Complex c33;
        c33.real = real - c11.real;
        c33.imag = imag - c11.imag;
        return c33;
    }
    void Display() const;
private:
    double real;
    double imag;
};

void Complex::Display() const
{
    cout << "(" << real << ", " << imag << ")" << endl;
}

int main()
{
    double r, m;
    cin >> r >> m;
    Complex c1(r, m);
    cin >> r >> m;
    Complex c2(r, m);
    Complex c3 = c1+c2;
    c3.Display();
    c3 = c1-c2;
    c3.Display();
    c3 -= c1;
    c3.Display();
    return 0;
}

 

  • 1
    点赞
  • 3
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值