1064 Complete Binary Search Tree

题目来源:PAT (Advanced Level) Practice

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

  • The left subtree of a node contains only nodes with keys less than the node's key.
  • The right subtree of a node contains only nodes with keys greater than or equal to the node's key.
  • Both the left and right subtrees must also be binary search trees.

A Complete Binary Tree (CBT) is a tree that is completely filled, with the possible exception of the bottom level, which is filled from left to right.

Now given a sequence of distinct non-negative integer keys, a unique BST can be constructed if it is required that the tree must also be a CBT. You are supposed to output the level order traversal sequence of this BST.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤1000). Then N distinct non-negative integer keys are given in the next line. All the numbers in a line are separated by a space and are no greater than 2000.

Output Specification:

For each test case, print in one line the level order traversal sequence of the corresponding complete binary search tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input:

10
1 2 3 4 5 6 7 8 9 0

Sample Output:

6 3 8 1 5 7 9 0 2 4

words:

Complete 完全的        recursively 递归地        properties 特性,财产       exception 例外,反对

题意:

给定n个正整数,构建一个完全二叉搜索树,并输出其层序遍历序列;

思路:

1. 由于是完全二叉树,所以使用数组cen[n+1]来存储该树;

2. 由于二叉搜索树地中序遍历序列是一个非递减序列,所以把给定的n个数按升序排列然后通过中序遍历地形式安插到对应数组的结点中去即可;

3. 直接输出完全二叉排序树的数组cen[]中的元素即可,因为层序遍历序列和二叉树在数组中的存储顺序一致;

//PAT ad 1064 Complete Binary Search Tree
#include <iostream>
using namespace std;
#include <queue>
#include <algorithm>
#define N 1000

int n;		//结点数 
int a[N];	//结点信息 


int k=0;
int cen[N+1];		//保存层序遍历结果
 
void inOrder(int t)		//中序遍历 
{
	if(t<=n)
	{
		inOrder(t*2);	//左子树 
		cen[t]=a[k++];
		inOrder(t*2+1);		//右子树 
	}
}
 
/*
0 1 2 3 4 5 6 7 8 9
*/
int main()
{
	int i;
	cin>>n;
	for(i=0;i<n;i++)
		cin>>a[i];
	sort(a,a+n);		//排序,升序 

	inOrder(1);
	
	for(i=1;i<n;i++)		//输出 
		cout<<cen[i]<<" ";
	cout<<cen[i]<<endl;
	
 } 

        

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值