1055 The World‘s Richest

题目来源:PAT (Advanced Level) Practice

Forbes magazine publishes every year its list of billionaires based on the annual ranking of the world's wealthiest people. Now you are supposed to simulate this job, but concentrate only on the people in a certain range of ages. That is, given the net worths of N people, you must find the M richest people in a given range of their ages.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers: N (≤105) - the total number of people, and K (≤103) - the number of queries. Then N lines follow, each contains the name (string of no more than 8 characters without space), age (integer in (0, 200]), and the net worth (integer in [−106,106]) of a person. Finally there are K lines of queries, each contains three positive integers: M (≤100) - the maximum number of outputs, and [Amin, Amax] which are the range of ages. All the numbers in a line are separated by a space.

Output Specification:

For each query, first print in a line Case #X: where X is the query number starting from 1. Then output the M richest people with their ages in the range [Amin, Amax]. Each person's information occupies a line, in the format

Name Age Net_Worth

The outputs must be in non-increasing order of the net worths. In case there are equal worths, it must be in non-decreasing order of the ages. If both worths and ages are the same, then the output must be in non-decreasing alphabetical order of the names. It is guaranteed that there is no two persons share all the same of the three pieces of information. In case no one is found, output None.

Sample Input:

12 4
Zoe_Bill 35 2333
Bob_Volk 24 5888
Anny_Cin 95 999999
Williams 30 -22
Cindy 76 76000
Alice 18 88888
Joe_Mike 32 3222
Michael 5 300000
Rosemary 40 5888
Dobby 24 5888
Billy 24 5888
Nobody 5 0
4 15 45
4 30 35
4 5 95
1 45 50

Sample Output:

Case #1:
Alice 18 88888
Billy 24 5888
Bob_Volk 24 5888
Dobby 24 5888
Case #2:
Joe_Mike 32 3222
Zoe_Bill 35 2333
Williams 30 -22
Case #3:
Anny_Cin 95 999999
Michael 5 300000
Alice 18 88888
Cindy 76 76000
Case #4:
None

words:

magazine 杂志        billionaire 亿万富翁         simulate 模拟,模仿        concentrate 集中,专注于

题意:

给定n个人的姓名、年龄、财富,然后按照查询要求输出年龄在区间[Amin,Amax]内最富有的m个人;

思路:

1. 用结构体数组p[]存储这n个人的信息(姓名、年龄、财富);

2. 按照财富最多、年龄最小、姓名字典序最小的规则对这n个人进行排序;

3. 按照给出的年龄区间和最大输出人数从头到尾遍历数组p[],输出符合要求的人的信息;若无人符合要求则输出“None”;

4. 由于输出的内容比较多,输出时使用printf()来防止程序超时

//PAT ad 1055 The World's Richest
#include <iostream> 
using namespace std;
#include <algorithm>
#define N 100005
struct	ab
{
	string name;
	int age;
	int netWorth;
}p[N];

bool cmp(ab x,ab y)			//排序 ,netWorth、age、name 
{
	if(x.netWorth==y.netWorth)
	{
		if(x.age==y.age)
			return x.name<y.name;	
		return x.age<y.age;
	}
	return x.netWorth>y.netWorth;
}

int main()
{
	int n,k,i;
	cin>>n>>k;cin.ignore();
	
	for(i=0;i<n;i++)	//输入 
		cin>>p[i].name>>p[i].age>>p[i].netWorth;cin.ignore();
	
	sort(p,p+n,cmp);	//排序 
		
	int m,amin,amax; 
	for(i=1;i<=k;i++)		//查询,输出 
	{
		scanf("%d %d %d",&m,&amin,&amax);
		
        printf("Case #%d:\n",i);
		int c=0;
		for(int j=0;j<n&&c<m;j++)
		{
			if(p[j].age>=amin&&p[j].age<=amax)
			{
                printf("%s %d %d\n",p[j].name.c_str(),p[j].age,p[j].netWorth);
				c++;		//由于输出比较多,使用cout会超时 
			}	
		}
		if(c==0)
				printf("None\n");
	}	
			
	
	return 0;
} 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值