ALDS1_3_B: Queue

题目
Queue
There are n processes in a queue. Each process has namei and timei. The round-robin scheduling handles the processes in order. A round-robin scheduler gives each process a quantum (a time slot) and interrupts the process if it is not completed by then. The process is resumed and moved to the end of the queue, then the scheduler handles the next process in the queue.

For example, we have the following queue with the quantum of 100ms.

A(150) - B(80) - C(200) - D(200)
First, process A is handled for 100ms, then the process is moved to the end of the queue with the remaining time (50ms).

B(80) - C(200) - D(200) - A(50)
Next, process B is handled for 80ms. The process is completed with the time stamp of 180ms and removed from the queue.

C(200) - D(200) - A(50)
Your task is to write a program which simulates the round-robin scheduling.

Input
n q
name1 time1
name2 time2
...
namen timen
In the first line the number of processes n and the quantum q are given separated by a single space.

In the following n lines, names and times for the n processes are given. namei and timei are separated by a single space.

Output
For each process, prints its name and the time the process finished in order.

Constraints
1 ≤ n ≤ 100000
1 ≤ q ≤ 1000
1 ≤ timei ≤ 50000
1 ≤ length of namei ≤ 10
1 ≤ Sum of timei ≤ 1000000

Sample Input 1
5 100
p1 150
p2 80
p3 200
p4 350
p5 20

Sample Output 1
p2 180
p5 400
p1 450
p3 550
p4 800

Notes
Template in C
代码块
#include <iostream>
#include <queue>
using namespace std;

struct Task{
    string name;
    int time;
};

int main(void)
{
    int i, n, q;
    cin>>n>>q;
    Task a[n];
    for(i=0; i<n; i++)
        cin>>a[i].name>>a[i].time;
    queue<Task> p;
    for(i=0; i<n; i++)
        p.push(a[i]);
    int time = 0;
    while(!p.empty())
    {
        Task temp = p.front();
        p.pop();
        if(temp.time>q)
        {
            time += q;
            temp.time -= q;
            p.push(temp);
        }
        else
        {
            time += temp.time;
            cout<<temp.name<<' '<<time<<endl;
        }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值