ALDS1_3_C: Doubly Linked List

题解
  1. 请使用更高速的输入输出函数,如果是C++则将cin改为scanf、cout改为printf,运行时间会降低很多。如果C++中不需要使用cin和cout则不需要包含头文件iostream,也不用再用std命名空间,改用scanf和printf只要包含cstdio就行了。
  2. 这题一开始以为是双向链表,实际上是双向循环链表,在设置头结点的时候要让head->next和head->prior都指向head。如果不视为循环链表,则deleteLast需要从头遍历到最后,导致时间超限。
  3. 删除操作和插入操作不同的是删除需要delete待删除结点,而插入不要。所以插入操作中一般只需要一个操作指针,而删除操作需要两个操作指针。
  4. 单链表中插入删除需要改变的结点只有待操作结点与其前驱,而双向链表中插入删除需要改变待操作结点与其前驱后继。因此在双向链表中的插删操作需要讨论待操作结点的后继是否为空,但如果是双向循环链表则不需要讨论。
题目
Doubly Linked List
Your task is to implement a double linked list.

Write a program which performs the following operations:

insert x: insert an element with key x into the front of the list.
delete x: delete the first element which has the key of x from the list. If there is not such element, you need not do anything.
deleteFirst: delete the first element from the list.
deleteLast: delete the last element from the list.

Input
The input is given in the following format:
n
command1
command2
...
commandn

In the first line, the number of operations n is given. In the following n lines, the above mentioned operations are given in the following format:
insert x
delete x
deleteFirst
deleteLast

Output
Print all the element (key) in the list after the given operations. Two consequtive keys should be separated by a single space.

Constraints
The number of operations ≤ 2,000,000
The number of delete operations ≤ 20
0 ≤ value of a key ≤ 109
The number of elements in the list does not exceed 106
For a delete, deleteFirst or deleteLast operation, there is at least one element in the list.

Sample Input 1
7
insert 5
insert 2
insert 3
insert 1
delete 3
insert 6
delete 5

Sample Output 1
6 1 2

Sample Input 2
9
insert 5
insert 2
insert 3
insert 1
delete 3
insert 6
delete 5
deleteFirst
deleteLast

Sample Output 2
1
代码块
#include <cstdio>

class ListNode
{
    ListNode *prior, *next;
    int data;
public:
    ListNode(){prior = NULL; next = NULL;}
    friend class LinkList;
};

class LinkList
{
    ListNode *head;
public:
    LinkList();
    ~LinkList();
    void Insert(int e);
    void Delete(int e);
    void DeleteFirst();
    void DeleteLast();
    void Display();
};

LinkList::LinkList()
{
    head = new ListNode;
    head->next = head;
    head->prior = head;
}

LinkList::~LinkList()
{
    delete head;
}

void LinkList::Insert(int e)
{
    ListNode *p;
    p = new ListNode;
    p->data = e;
    p->next = head->next;
    p->prior = head;
    head->next->prior = p;
    head->next = p;
}

void LinkList::Delete(int e)
{
    ListNode *p, *q;
    p = head;
    q = p->next;
    while(q!=head && q->data!=e)
    {
        p = p->next;
        q = q->next;
    }
    if(q!=head)
    {
        q->next->prior = p;
        p->next = q->next;
        delete q;
    }
}

void LinkList::DeleteFirst()
{
    ListNode *p, *q;
    p = head;
    q = p->next;
    if(q!=head)
    {
        p->next = q->next;
        q->next->prior = p;
        delete q;
    }
}

void LinkList::DeleteLast()
{
    ListNode *p, *q;
    p = head;
    q = p->prior;
    if(q!=head)
    {
        p->prior = q->prior;
        q->prior->next = p;
        delete q;
    }
}

void LinkList::Display()
{
    ListNode *q;
    q = head->next;
    while(q!=head)
    {
        if(q->next!=head)
            printf("%d ", q->data);
        else
            printf("%d\n", q->data);
        q = q->next;
    }
}

int main(void)
{
    LinkList myList;
    int i, n;
    scanf("%d", &n);
    for(i=0; i<n; i++)
    {
        char a[20];
        int b;
        scanf("%s", a);
        if(a[6]=='F')
            myList.DeleteFirst();
        else if(a[6]=='L')
            myList.DeleteLast();
        else if(a[0]=='i')
        {
            scanf("%d", &b);
            myList.Insert(b);
        }
        else if(a[0]=='d')
        {
            scanf("%d", &b);
            myList.Delete(b);
        }
    }
    myList.Display();
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值