ALDS1_5_C: Koch Curve

题目
Koch Curve
Write a program which reads an integer n and draws a Koch curve based on recursive calles of depth n.

The Koch curve is well known as a kind of fractals.

You can draw a Koch curve in the following algorithm:

Divide a given segment (p1, p2) into three equal segments.
Replace the middle segment by the two sides of an equilateral triangle (s, u, t) of the same length as the segment.
Repeat this procedure recursively for new segments (p1, s), (s, u), (u, t), (t, p2).

在这里插入图片描述

You should start (0, 0), (100, 0) as the first segment.

Input
An integer n is given.

Output
Print each point (x, y) of the Koch curve. Print a point in a line. You should start the point(0, 0), which is the endpoint of the first segment and end with the point (100, 0), the other endpoint so that you can draw the Koch curve as an unbroken line. Each solution should be given as a decimal with an arbitrary number of fractional digits, and with an absolute error of at most 10-4.

Constraints
0 ≤ n ≤ 6

Sample Input 1
1

Sample Output 1
0.00000000 0.00000000
33.33333333 0.00000000
50.00000000 28.86751346
66.66666667 0.00000000
100.00000000 0.00000000

Sample Input 2
2

Sample Output 2
0.00000000 0.00000000
11.11111111 0.00000000
16.66666667 9.62250449
22.22222222 0.00000000
33.33333333 0.00000000
38.88888889 9.62250449
33.33333333 19.24500897
44.44444444 19.24500897
50.00000000 28.86751346
55.55555556 19.24500897
66.66666667 19.24500897
61.11111111 9.62250449
66.66666667 0.00000000
77.77777778 0.00000000
83.33333333 9.62250449
88.88888889 0.00000000
100.00000000 0.00000000
代码块
#include <iostream>
#include <iomanip>
using namespace std;

void Koch(pair<double, double> a, pair<double, double> b, int n)
{
    if(!n)
    {
        cout<<fixed<<setprecision(8)<<a.first<<' '<<a.second<<endl;
        return;
    }
    double x = b.first-a.first;
    double y = b.second-a.second;
    pair<double, double> c(a.first+x/3, a.second+y/3);
    pair<double, double> d1(a.first, a.second+2*y/3);
    pair<double, double> d2(b.first, a.second+y/3);
    pair<double, double> d3(a.first+x/2, a.second+1.7320508075*x/6);
    pair<double, double> e(a.first+2*x/3, a.second+2*y/3);
    Koch(a, c, n-1);
    if(y>0 & x>0)
    {
        Koch(c, d1, n-1);
        Koch(d1, e, n-1);
    }
    else if(y<0 & x>0)
    {
        Koch(c, d2, n-1);
        Koch(d2, e, n-1);
    }
    else if(y>0 & x<0)
    {
        Koch(c, d2, n-1);
        Koch(d2, e, n-1);
    }
    else if(y<0 & x<0)
    {
        Koch(c, d1, n-1);
        Koch(d1, e, n-1);
    }
    else
    {
        Koch(c, d3, n-1);
        Koch(d3, e, n-1);
    }
    Koch(e, b, n-1);
}

int main(void)
{
    int n;
    cin>>n;
    pair<double, double> a, b;
    a.first = 0;
    a.second = 0;
    b.first = 100;
    b.second = 0;
    Koch(a, b, n);
    cout<<fixed<<setprecision(8)<<b.first<<' '<<b.second<<endl;
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值