1136 A Delayed Palindrome (20 分)--PAT甲级(大数处理)

Consider a positive integer N written in standard notation with k+1 digits ai as ak⋯a1
​a0 with 0≤ai<10 for all i and ak >0. Then N is palindromic if and only if ai = ak−i for all i. Zero is written 0 and is also palindromic by definition.

Non-palindromic numbers can be paired with palindromic ones via a series of operations. First, the non-palindromic number is reversed and the result is added to the original number. If the result is not a palindromic number, this is repeated until it gives a palindromic number. Such number is called a delayed palindrome. (Quoted from https://en.wikipedia.org/wiki/Palindromic_number )

Given any positive integer, you are supposed to find its paired palindromic number.

Input Specification:
Each input file contains one test case which gives a positive integer no more than 1000 digits.

Output Specification:
For each test case, print line by line the process of finding the palindromic number. The format of each line is the following:

A + B = C
where A is the original number, B is the reversed A, and C is their sum. A starts being the input number, and this process ends until C becomes a palindromic number – in this case we print in the last line C is a palindromic number.; or if a palindromic number cannot be found in 10 iterations, print Not found in 10 iterations. instead.

Sample Input 1:
97152
结尾无空行
Sample Output 1:
97152 + 25179 = 122331
122331 + 133221 = 255552
255552 is a palindromic number.
结尾无空行
Sample Input 2:
196
结尾无空行
Sample Output 2:
196 + 691 = 887
887 + 788 = 1675
1675 + 5761 = 7436
7436 + 6347 = 13783
13783 + 38731 = 52514
52514 + 41525 = 94039
94039 + 93049 = 187088
187088 + 880781 = 1067869
1067869 + 9687601 = 10755470
10755470 + 07455701 = 18211171
Not found in 10 iterations.
结尾无空行

题目分析:给出一个不超过1000位的数字,判断其是否是回文数,若不是则加上自己的倒数后,继续判断,直至出现回文数或判断了10次截止。

这题考察的是a+b的大数运算,模板部分可以参考我的算法模板,下面给出代码

#include<iostream>
#include<vector>
#include<algorithm>
using namespace std;

vector<int> add(vector<int> &a, vector<int> &b){
    vector<int> C;
    int t = 0;
    for(int  i = 0; i < a.size() || i < b.size(); i ++){
        if(i < a.size()) t += a[i];
        if(i < b.size()) t += b[i];
        C.push_back(t % 10);
        t /= 10;
    }
    if(t) C.push_back(1);
    reverse(C.begin(), C.end());
    return C;
}

bool prlindrome(vector<int> &a){
    for(int i = 0; i < a.size() / 2; i ++){
        if(a[i] != a[a.size() - i - 1]) return false;
    }
    return true;
}

void print(vector<int> &v){
	for(int i = 0; i < v.size(); i ++){
		cout << v[i]; 
	}
}

int main(){
    string str;
    cin >> str;
    vector<int> a, b, t;
    for(int i = 0; i < str.size(); i ++) a.push_back(str[i] - '0');
    bool flag = false;
    for(int i = 0; i < 10; i ++){
        if(prlindrome(a)){
            flag = true;
            break;
        }
        b = a;
        reverse(a.begin(), a.end());
        t = add(a, b);
        print(b);
        cout << " + ";
		print(a);
		cout << " = ";
		print(t);
		cout << endl;
		a = t;
    }
    if(!flag) puts("Not found in 10 iterations.");
    else{
		print(a); 
		printf(" is a palindromic number.");
	}
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值