QuestionDescribe:
This time you are asked to tell the difference between the lowest grade of all the male students and the highest grade of all the female students.
Input Specification:
Each input file contains one test case. Each case contains a positive integer N, followed by N lines of student information. Each line contains a student’s name, gender, ID and grade, separated by a space, where name and ID are strings of no more than 10 characters with no space, gender is either F (female) or M (male), and grade is an integer between 0 and 100. It is guaranteed that all the grades are distinct.
Output Specification:
For each test case, output in 3 lines. The first line gives the name and ID of the female student with the highest grade, and the second line gives that of the male student with the lowest grade. The third line gives the difference gradeF −gradeM . If one such kind of student is missing, output Absent in the corresponding line, and output NA in the third line instead.
Sample Input 1:
3
Joe M Math990112 89
Mike M CS991301 100
Mary F EE990830 95
结尾无空行
Sample Output 1:
Mary EE990830
Joe Math990112
6
结尾无空行
题目解读:找出女生最高分和男生最低分的差值,输出男生姓名 ID 输出女生姓名 ID, 最后输出差值,若无男生/女生输出Absent,最后行输出NA。
题目分析:定义两组变量就完了。
#include<iostream>
using namespace std;
int main(){
string mname = "", fname = "", mid = "", fid = "";
int n, mlow = 100, fhigh = 0;
cin >> n;
for(int i = 0; i < n; i ++){
string name, sex, id;
int score;
cin >> name >> sex >> id >> score;
if(sex == "M"){
if(mlow > score){
mlow = score;
mname = name;
mid = id;
}
}else{
if(fhigh < score){
fhigh = score;
fname = name;
fid = id;
}
}
}
if(fname == ""){
cout << "Absent" << endl;
}else{
cout << fname << ' ' << fid << endl;
}
if(mname == ""){
cout << "Absent" << endl;
}else{
cout << mname << ' ' << mid << endl;
}
if(mname=="" || fname==""){
cout << "NA" << endl;
}else{
cout << fhigh - mlow << endl;
}
return 0;
}