1139 First Contact (30 分)--PAT甲级(中级模拟)

Unlike in nowadays, the way that boys and girls expressing their feelings of love was quite subtle in the early years. When a boy A had a crush on a girl B, he would usually not contact her directly in the first place. Instead, he might ask another boy C, one of his close friends, to ask another girl D, who was a friend of both B and C, to send a message to B – quite a long shot, isn’t it? Girls would do analogously.

Here given a network of friendship relations, you are supposed to help a boy or a girl to list all their friends who can possibly help them making the first contact.

Input Specification:
Each input file contains one test case. For each case, the first line gives two positive integers N (1 < N ≤ 300) and M, being the total number of people and the number of friendship relations, respectively. Then M lines follow, each gives a pair of friends. Here a person is represented by a 4-digit ID. To tell their genders, we use a negative sign to represent girls.

After the relations, a positive integer K (≤ 100) is given, which is the number of queries. Then K lines of queries follow, each gives a pair of lovers, separated by a space. It is assumed that the first one is having a crush on the second one.

Output Specification:
For each query, first print in a line the number of different pairs of friends they can find to help them, then in each line print the IDs of a pair of friends.

If the lovers A and B are of opposite genders, you must first print the friend of A who is of the same gender of A, then the friend of B, who is of the same gender of B. If they are of the same gender, then both friends must be in the same gender as theirs. It is guaranteed that each person has only one gender.

The friends must be printed in non-decreasing order of the first IDs, and for the same first ones, in increasing order of the seconds ones.

Sample Input:
10 18
-2001 1001
-2002 -2001
1004 1001
-2004 -2001
-2003 1005
1005 -2001
1001 -2003
1002 1001
1002 -2004
-2004 1001
1003 -2002
-2003 1003
1004 -2002
-2001 -2003
1001 1003
1003 -2001
1002 -2001
-2002 -2003
5
1001 -2001
-2003 1001
1005 -2001
-2002 -2004
1111 -2003
结尾无空行
Sample Output:
4
1002 2004
1003 2002
1003 2003
1004 2002
4
2001 1002
2001 1003
2002 1003
2002 1004
0
1
2003 2001
0
结尾无空行

题目分析:给出n总人数和m总关系数,同学a要与同学d约会,需要找到a的同性朋友b和同学d的同性朋友c,d和c相互之间认识才可以约会。给出n和m,得出b与c的个数以及所有人数。

1. 可以选择将所有同性关系都存入vector< int> rel[10000]中,将所有关系存入arr[]中。
2. 找出与a有关的所有关系b和与d有关的所有关系c。
3. 判断bc之间是否有关系,有关则压入res中。
4. 对res进行排序,后输出。

注意:同性的情况,同性只能找同性。

#include<iostream>
#include<vector>
#include<algorithm>
using namespace std;

struct node{
	int a, b;
};
bool cmp(node x, node y){
	return x.a != y.a ? x.a < y.a : x.b < y.b;
}
map<int, bool> arr;
int main(){
	int n, m, k;
	string a, b;
	scanf("%d%d", &n, &m);
	vector<int> v[10000];
	while(m --){
		cin >> a >> b;//注意使用int会有数据过不去,原因测试点中有-0000这样的数据
		if(a.size() == b.size()){
			v[abs(stoi(a))].push_back(abs(stoi(b)));			
			v[abs(stoi(b))].push_back(abs(stoi(a)));
		} 
		arr[abs(stoi(a)) * 10000 + abs(stoi(b))] = arr[abs(stoi(b)) * 10000 + abs(stoi(a))] = true;
	}
	scanf("%d", &k);
	while(k --){
		int c, d;
		scanf("%d%d", &c, &d);
		vector<node> ans;
		for(int i = 0; i < v[abs(c)].size(); i ++){
			for(int j = 0; j < v[abs(d)].size(); j ++){
				if(v[abs(c)][i] == abs(d) || v[abs(d)][j] == abs(c)) continue;
				if(arr[v[abs(c)][i] * 10000 + v[abs(d)][j]] == true){
					ans.push_back(node{v[abs(c)][i], v[abs(d)][j]});
				}
			}
		}
		sort(ans.begin(), ans.end(), cmp);
		printf("%d\n", ans.size());
		for(int i = 0; i < ans.size(); i ++)
			printf("%04d %04d\n", ans[i].a, ans[i].b);
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值