PAT甲级1022 C++

PAT甲级1022

题目描述

A Digital Library contains millions of books, stored according to their titles, authors, key words of their abstracts, publishers, and published years. Each book is assigned an unique 7-digit number as its ID. Given any query from a reader, you are supposed to output the resulting books, sorted in increasing order of their ID’s.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N N N ( ≤ 1 0 4 ≤10^4 104) which is the total number of books. Then N N N blocks follow, each contains the information of a book in 6 lines:

  • Line #1: the 7-digit ID number;
  • Line #2: the book title – a string of no more than 80 characters;
  • Line #3: the author – a string of no more than 80 characters;
  • Line #4: the key words – each word is a string of no more than 10 characters without any white space, and the keywords are separated by
    exactly one space;
  • Line #5: the publisher – a string of no more than 80 characters;
  • Line #6: the published year – a 4-digit number which is in the range [ 1000 , 3000 ] [1000, 3000] [1000,3000].

It is assumed that each book belongs to one author only, and contains no more than 5 key words; there are no more than 1000 distinct key words in total; and there are no more than 1000 distinct publishers.

After the book information, there is a line containing a positive integer M ( ≤ 1000 ) M (≤1000) M(1000) which is the number of user’s search queries. Then M M M lines follow, each in one of the formats shown below:

  • 1: a book title
  • 2: name of an author
  • 3: a key word
  • 4: name of a publisher
  • 5: a 4-digit number representing the year

Output Specification:

For each query, first print the original query in a line, then output the resulting book ID’s in increasing order, each occupying a line. If no book is found, print Not Found instead.

Sample Input:

3
1111111
The Testing Book
Yue Chen
test code debug sort keywords
ZUCS Print
2011
3333333
Another Testing Book
Yue Chen
test code sort keywords
ZUCS Print2
2012
2222222
The Testing Book
CYLL
keywords debug book
ZUCS Print2
2011
6
1: The Testing Book
2: Yue Chen
3: keywords
4: ZUCS Print
5: 2011
3: blablabla

Sample Output:

1: The Testing Book
1111111
2222222
2: Yue Chen
1111111
3333333
3: keywords
1111111
2222222
3333333
4: ZUCS Print
1111111
5: 2011
1111111
2222222
3: blablabla
Not Found

思路分析

本题目的主要目的是根据输入来查找对应的ID,所以应该选择查找效率较高的数据结构。std::mapstd::set可以满足需求。因读入的是字符串,所以要用std::string作为std::map的键,鉴于keyword可以有多个,因此要用另外一个容器存储每一个keyword对应的ID,所以std::map的值类型应为std::set。这同样是为了提高查找效率。

注意点

  1. keyword要按空格分隔开,分隔开的每一个keyword都要映射到一个ID集合。
  2. 注意输出格式,ID为7位,此处将ID设为int,所以使用printf输出时,一定要用"%07d"格式化,否则测试点3、4不通过!
  3. 使用scanf读入ID后,一定要吸收换行符,否则std::getline会将换行读入。

C++ 程序

#include <iostream>
#include <map>
#include <set>
#include <string>

int main() {
    std::map<std::string, std::set<int>> mp[5];
    int n, m, p, id;
    std::string buf;
    scanf("%d", &n);
    for (int i = 0; i < n; ++i) {
        scanf("%d\n", &id);
        for (int j = 0; j < 5; ++j) {
            if (j == 2) {
                while (std::cin >> buf) {
                    mp[j][buf].insert(id);
                    if (std::cin.get() == '\n') break;
                }
            } else {
                std::getline(std::cin, buf);
                mp[j][buf].insert(id);
            }
        }
    }
    scanf("%d\n", &m);
    for (int i = 0; i < m; ++i) {
        scanf("%d: ", &p);
        std::getline(std::cin, buf);
        printf("%d: %s\n", p--, buf.c_str());
        if (mp[p].find(buf) == mp[p].end()) {
            printf("Not Found\n");
            continue;
        }
        for (auto& num : mp[p][buf]) {
            printf("%07d\n", num);
        }
    }
    return 0;
}

上面的程序中注意读入keyword时的处理。在此使用std::cin读入每一个keyword,因std::cin读入字符串是以空格或换行为结束标志的,所以自然达到了分隔字符串的目的。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值