[KMP]CF1029A

文章讲述了如何解决一个编程问题,即给定一个字符串t和一个整数k,构造一个最小长度的字符串s,使其包含k个子串与t相等。关键在于找出t的最小循环节并根据k进行适当的构造。
摘要由CSDN通过智能技术生成

Many Equal Substrings

题面翻译

题目描述:

你有一个字符串t,它由n个字母组成。

定义一个字符串s的子串为s[l…r],表示从位置l到r构成的一个新的串。

你的目标是构造一个字符串s,使得它的可能长度最小,要求s中存在k个位置i,可以找到k个以i为出发点的子串t。

输入: 第一行输入两个整数n和k,表示t的长度和需要k个子串

第二行输入字符串t

输出:

输出满足条件的长度最小的s。题目保证答案唯一。

题目描述

You are given a string $ t $ consisting of $ n $ lowercase Latin
letters and an integer number $ k $ .

Let’s define a substring of some string $ s $ with indices from $ l $
to $ r $ as $ s[l \dots r] $ .

Your task is to construct such string $ s $ of minimum possible length
that there are exactly $ k $ positions $ i $ such that $ s[i \dots i +
n - 1] = t $ . In other words, your task is to construct such string $
s $ of minimum possible length that there are exactly $ k $ substrings
of $ s $ equal to $ t $ .

It is guaranteed that the answer is always unique.

输入格式

The first line of the input contains two integers $ n $ and $ k $ ( $
1 \le n, k \le 50 $ ) — the length of the string $ t $ and the number
of substrings.

The second line of the input contains the string $ t $ consisting of
exactly $ n $ lowercase Latin letters.

输出格式

Print such string $ s $ of minimum possible length that there are
exactly $ k $ substrings of $ s $ equal to $ t $ .

It is guaranteed that the answer is always unique.

样例 #1

样例输入 #1

3 4 aba

样例输出 #1

ababababa

样例 #2

样例输入 #2

3 2 cat

样例输出 #2

catcat

看到这道题要求的答案,想到了熟悉的循环节问题,就从这入手吧。
还是先求出来 t t t的最小的循环节(记作 p p p),并根据 k k k进行多次构造。

但是,通过样例一可以发现,构造出来的 s s s可能不是恰好由整数个 p p p构成。
看样例一,可以发现最后恰好是由 p m t [ n − 1 ] pmt[n-1] pmt[n1]构成。

根据题意,可以总结出:前面输出 k − 1 k-1 k1个循环节,后面输出 t t t即可。
因为前面的 k − 1 k-1 k1个循环节首尾相连,已经是构成了 k − 1 k-1 k1 t t t结构了。

AC代码

#include<bits/stdc++.h>
using namespace std;
using ll=long long;
const int MAXN=1e6+10;
int pmt[MAXN],n,k;
void get_pmt(const string &s){
    for(int i=1,j=0;i<s.length();i++){
        while(j&&s[i]!=s[j])j=pmt[j-1];
        if(s[i]==s[j])j++;
        pmt[i]=j;
    }
}
int main(){
    ios::sync_with_stdio(0),cin.tie(0);
    string s;
    cin>>n>>k>>s;
    get_pmt(s);
    for(int i=1;i<=k-1;i++){
        for(int j=0;j<s.length()-pmt[s.length()-1];j++){
            cout<<s[j];
        }
    }
    cout<<s;
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值