C - Currency Exchange(图论,最短路,bellman判断正负权)

Several currency exchange points are working in our city. Let us suppose that each point specializes in two particular currencies and performs exchange operations only with these currencies. There can be several points specializing in the same pair of currencies. Each point has its own exchange rates, exchange rate of A to B is the quantity of B you get for 1A. Also each exchange point has some commission, the sum you have to pay for your exchange operation. Commission is always collected in source currency.
For example, if you want to exchange 100 US Dollars into Russian Rubles at the exchange point, where the exchange rate is 29.75, and the commission is 0.39 you will get (100 - 0.39) * 29.75 = 2963.3975RUR.
You surely know that there are N different currencies you can deal with in our city. Let us assign unique integer number from 1 to N to each currency. Then each exchange point can be described with 6 numbers: integer A and B - numbers of currencies it exchanges, and real RAB, CAB, RBA and CBA - exchange rates and commissions when exchanging A to B and B to A respectively.
Nick has some money in currency S and wonders if he can somehow, after some exchange operations, increase his capital. Of course, he wants to have his money in currency S in the end. Help him to answer this difficult question. Nick must always have non-negative sum of money while making his operations.
Input
The first line of the input contains four numbers: N - the number of currencies, M - the number of exchange points, S - the number of currency Nick has and V - the quantity of currency units he has. The following M lines contain 6 numbers each - the description of the corresponding exchange point - in specified above order. Numbers are separated by one or more spaces. 1<=S<=N<=100, 1<=M<=100, V is real number, 0<=V<=103.
For each point exchange rates and commissions are real, given with at most two digits after the decimal point, 10-2<=rate<=102, 0<=commission<=102.
Let us call some sequence of the exchange operations simple if no exchange point is used more than once in this sequence. You may assume that ratio of the numeric values of the sums at the end and at the beginning of any simple sequence of the exchange operations will be less than 104.
Output
If Nick can increase his wealth, output YES, in other case output NO to the output file.
Sample Input
3 2 1 20.0
1 2 1.00 1.00 1.00 1.00
2 3 1.10 1.00 1.10 1.00
Sample Output
YES
题意:
第一行输入N–货币种类,M–交换货币的场所个数,S–当前此人拥有的货币种类,V—此人拥有的货币价值(自然是他拥有的那种货币的价值)
第二行 6 个数字,a,b,rate1,fee1,rate2,fee2;分别表示:a种货币,b种货币,a货币换到b货币的汇率,a货币到b货币的佣金(佣金从本金里扣,例如,我现在有100a本金,则转换到b类时就变成了(100-fee1)*rate1,),后面的就是b到a的了
然后判断经过一系列转换最后在变成开始的1货币种类时,价值是否增值。
还有注意题中给的数据类型

思路:bellman——ford判断正权2

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<iostream>
#include<queue>
using namespace std;
const int INF=33333;
double dis[1005];
struct mony{
	int a,b;
	double rate,fee;
}d[INF];
int n,m,s;
double v;
int bellman()
{
	memset(dis,0,sizeof(dis));//求最大权重和,初始为0, 
	dis[s]=v;//初始s类货币的价值 
	for(int i=1;i<n;i++)//n-1次不断更新dis,使其更大 
	{
		for(int j=0;j<2*m;j++)
		{
			//if(dis[d[j].b]<(dis[d[j].a]-d[j].fee)*d[j].rate)
		// dis[d[j].b]=(dis[d[j].a]-d[j].fee)*d[j].rate;
		 dis[d[j].b]=max(dis[d[j].b],(dis[d[j].a]-d[j].fee)*d[j].rate);
		}
	}
	for(int j=0;j<2*m;j++)//判断成环为正为负 
	{
		if(dis[d[j].b]<(dis[d[j].a]-d[j].fee)*d[j].rate)//注意,这里是<, 
		return 1;
	}
	return 0;
}
int main() 
{
  cin>>n>>m>>s>>v;
  for(int i=0;i<m;i++)
  {
  	int a,b;
  	double r1,y1,r2,y2;
  	cin>>a>>b>>r1>>y1>>r2>>y2;
  	d[i].a=a;
  	d[i].b=b;
  	d[i].rate=r1;
  	d[i].fee=y1;
  	d[i+m].a=b;
  	d[i+m].b=a;
  	d[i+m].rate=r2;
  	d[i+m].fee=y2;
  }
  if( bellman())
  cout<<"YES"<<endl;
  else
  cout<<"NO"<<endl;
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值