G - Navigation Nightmare(并查集)

Farmer John’s pastoral neighborhood has N farms (2 <= N <= 40,000), usually numbered/labeled 1…N. A series of M (1 <= M < 40,000) vertical and horizontal roads each of varying lengths (1 <= length <= 1000) connect the farms. A map of these farms might look something like the illustration below in which farms are labeled F1…F7 for clarity and lengths between connected farms are shown as (n):
F1 — (13) ---- F6 — (9) ----- F3

        |                                 |

       (3)                                |

        |                                (7)

       F4 --- (20) -------- F2            |

        |                                 |

       (2)                               F5

        | 

       F7 

Being an ASCII diagram, it is not precisely to scale, of course.

Each farm can connect directly to at most four other farms via roads that lead exactly north, south, east, and/or west. Moreover, farms are only located at the endpoints of roads, and some farm can be found at every endpoint of every road. No two roads cross, and precisely one path
(sequence of roads) links every pair of farms.

FJ lost his paper copy of the farm map and he wants to reconstruct it from backup information on his computer. This data contains lines like the following, one for every road:

There is a road of length 10 running north from Farm #23 to Farm #17
There is a road of length 7 running east from Farm #1 to Farm #17

As FJ is retrieving this data, he is occasionally interrupted by questions such as the following that he receives from his navigationally-challenged neighbor, farmer Bob:

What is the Manhattan distance between farms #1 and #23?

FJ answers Bob, when he can (sometimes he doesn’t yet have enough data yet). In the example above, the answer would be 17, since Bob wants to know the “Manhattan” distance between the pair of farms.
The Manhattan distance between two points (x1,y1) and (x2,y2) is just |x1-x2| + |y1-y2| (which is the distance a taxicab in a large city must travel over city streets in a perfect grid to connect two x,y points).

When Bob asks about a particular pair of farms, FJ might not yet have enough information to deduce the distance between them; in this case, FJ apologizes profusely and replies with “-1”.
Input

  • Line 1: Two space-separated integers: N and M

  • Lines 2…M+1: Each line contains four space-separated entities, F1,

      F2, L, and D that describe a road. F1 and F2 are numbers of
    
      two farms connected by a road, L is its length, and D is a
    
      character that is either 'N', 'E', 'S', or 'W' giving the
    
      direction of the road from F1 to F2.
    
  • Line M+2: A single integer, K (1 <= K <= 10,000), the number of FB’s

      queries
    
  • Lines M+3…M+K+2: Each line corresponds to a query from Farmer Bob

      and contains three space-separated integers: F1, F2, and I. F1
    
      and F2 are numbers of the two farms in the query and I is the
    
      index (1 <= I <= M) in the data after which Bob asks the
    
      query. Data index 1 is on line 2 of the input data, and so on.
    

Output

  • Lines 1…K: One integer per line, the response to each of Bob’s

      queries.  Each line should contain either a distance
    
      measurement or -1, if it is impossible to determine the
    
      appropriate distance.
    

Sample Input
7 6
1 6 13 E
6 3 9 E
3 5 7 S
4 1 3 N
2 4 20 W
4 7 2 S
3
1 6 1
1 4 3
2 6 6
Sample Output
13
-1
10
Hint
At time 1, FJ knows the distance between 1 and 6 is 13.
At time 3, the distance between 1 and 4 is still unknown.
At the end, location 6 is 3 units west and 7 north of 2, so the distance is 10.

#include <cstdio>
#include <cmath>
#include <string.h>
#include <iostream>
#include <algorithm>
#include <vector>
#include <queue>
#include <stack>
using namespace std;
int pre[40010];
char map[40010][50];
int x[40010],y[40010];
int find(int xx)
{
	if(pre[xx]==xx)
	return xx;
	else
	{
		int t=pre[xx];
		pre[xx]=find(t);
		x[xx]+=x[t];
		y[xx]+=y[t];
		return pre[xx];
	}
}
void join(int a,int b,int dx,int dy)
{
	int fx=find(a);
	int fy=find(b);
	if(fx!=fy)
	{
		pre[fy]=fx;
		x[fy]=x[a]-x[b]+dx;
		y[fy]=y[a]-y[b]+dy;
	}
}
int dist(int x1,int x2,int y1,int y2)
{
	return abs(x1-x2)+abs(y1-y2);
}
int main()
{
	int n,m;
	scanf("%d%d",&n,&m);
	for(int i=0;i<=n;i++)
	{
		pre[i]=i;
		x[i]=y[i]=0;
	}
	getchar();//与下面的sscanf是一起的,不可用cin来省略 
	for(int i=0;i<m;i++)
	gets(map[i]);//输出m行字符串 
	int k;
	//cin>>k;
	scanf("%d",&k);
	int num=0;
	 while(k--)
	 {
     	int a,b,c;
     	//cin>>a>>b>>c;
     	scanf("%d%d%d",&a,&b,&c);
     	for(int i=num;i<c;i++)
     	{
     		int aa,bb,l;
     		int dx=0,dy=0;
     		char s[3];
     		sscanf(map[i],"%d %d %d %s",&aa,&bb,&l,s);
     		switch(s[0])
     		{
     			case 'E':dx+=l;break;
     			case 'W':dx-=l;break;
     			case 'N':dy+=l;break;
     			case 'S':dy-=l;break;
			 }
			 join(aa,bb,dx,dy);
		 }
		 num=c;
		 int fx=find(a);
		 int fy=find(b);
		 if(fx!=fy)//不在一个集合中 
		 printf("-1\n");
		 else
		 printf("%d\n",dist(x[a],x[b],y[a],y[b]));//不能用cout,为啥?不知道,可能时间的方面吧 
	 }
   return 0; 
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值