H - Arctic Network(最小生成树)

The Department of National Defence (DND) wishes to connect several northern outposts by a wireless network. Two different communication technologies are to be used in establishing the network: every outpost will have a radio transceiver and some outposts will in addition have a satellite channel.
Any two outposts with a satellite channel can communicate via the satellite, regardless of their location. Otherwise, two outposts can communicate by radio only if the distance between them does not exceed D, which depends of the power of the transceivers. Higher power yields higher D but costs more. Due to purchasing and maintenance considerations, the transceivers at the outposts must be identical; that is, the value of D is the same for every pair of outposts.

Your job is to determine the minimum D required for the transceivers. There must be at least one communication path (direct or indirect) between every pair of outposts.
Input
The first line of input contains N, the number of test cases. The first line of each test case contains 1 <= S <= 100, the number of satellite channels, and S < P <= 500, the number of outposts. P lines follow, giving the (x,y) coordinates of each outpost in km (coordinates are integers between 0 and 10,000).
Output
For each case, output should consist of a single line giving the minimum D required to connect the network. Output should be specified to 2 decimal points.
Sample Input
1
2 4
0 100
0 300
0 600
150 750
Sample Output
212.13
题意:
t个测试
s个通讯点(2个点之间不用建筑路),p个地点。
接下来p行
每行2点,表示每一个地点的x,y坐标。
求D,
即求最短路中,除去s-1条(原因代码中有注释)距离大的边之后最大的路径长。

#include <cstdio>
#include <cmath>
#include <cstring>
#include <iostream>
#include <algorithm>
using namespace std;
const int N=888;
double MAX=999999999.0;
int n,s;
double dist[N],map[N][N];
int biao[N];
double sum[N];
double x[N],y[N];
void prim()//最小生成树模板 
{
    for(int i=1;i<=n;i++)
    {
    	dist[i]=map[1][i];
    	biao[i]=0; 
	}
	dist[1]=0;
	biao[1]=1;
		int k;
		double minn;
		int l=0;
	for(int i=1;i<n;i++)
	{
		minn=MAX;
	
		for(int j=1;j<=n;j++)
		{
			if(biao[j]==0&&minn>dist[j])
			{
				minn=dist[j];
				k=j;
			}
		}
		sum[l++]=minn;
		biao[k]=1;
		for(int j=1;j<=n;j++)
		{
			if(!biao[j]&&dist[j]>map[k][j])
			{
				dist[j]=map[k][j];
			}
		}
		
	}
	sort(sum,sum+l);
	s-=1;//2个点一条路径,3个点2条路,4个点3条路,所以开始要先减1.
	for(int i=l-1;i>=0;i--)
	{
		if(s==0)
		{
			printf("%.2f\n",sum[i]);//输出这里是f,不是lf因为这个错误改了好几个小时!!!!
		//	cout<<sum[i]<<endl;
			break;
		}
		s--;
	}
}

int main()
{
  
 int t;
 cin>>t;
 while(t--)
 {
 	cin>>s>>n;
 	for(int i=1;i<=n;i++)
 	{
 		cin>>x[i]>>y[i];
 		for(int j=1;j<i;j++)
 		{
 			double len;
 			len=sqrt(pow(x[i]-x[j],2.0)+pow(y[i]-y[j],2.0));
 			map[i][j]=map[j][i]=len;
		}
	 }
	 prim();
  } 
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值