POJ 3974 Palindrome(回文哈希+二分)

Palindrome

Description

Andy the smart computer science student was attending an algorithms class when the professor asked the students a simple question, “Can you propose an efficient algorithm to find the length of the largest palindrome in a string?”

A string is said to be a palindrome if it reads the same both forwards and backwards, for example “madam” is a palindrome while “acm” is not.

The students recognized that this is a classical problem but couldn’t come up with a solution better than iterating over all substrings and checking whether they are palindrome or not, obviously this algorithm is not efficient at all, after a while Andy raised his hand and said “Okay, I’ve a better algorithm” and before he starts to explain his idea he stopped for a moment and then said “Well, I’ve an even better algorithm!”.

If you think you know Andy’s final solution then prove it! Given a string of at most 1000000 characters find and print the length of the largest palindrome inside this string.

Input

Your program will be tested on at most 30 test cases, each test case is given as a string of at most 1000000 lowercase characters on a line by itself. The input is terminated by a line that starts with the string “END” (quotes for clarity).

Output

For each test case in the input print the test case number and the length of the largest palindrome.

Sample Input

abcbabcbabcba
abacacbaaaab
END

Sample Output

Case 1: 13
Case 2: 6

题意

给你一个字符串,求出所有回文子串的最大长度

思路

当然就是想到用回文哈希啦,但是怎么判断这个子串是不是回文串呢,只需要正着哈希一遍然后再倒着哈希一遍最后看一下两个哈希值是否相等就可以,然后就是咱们精彩刺激的回文子串定位环节了,就是找一个中心点然后二分半个字串的长度,这里有两种情况,这个子串长度是奇数,这个子串长度是偶数,然后分别判断一下就好了,因为如果不分开看的话会出问题,下面来看一下代码把

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
const int N = 1000010,P = 13331;
typedef unsigned long long ull;
char s1[N],s2[N];
ull h1[N],p[N],h2[N];
ull get1(int l,int r){
	return h1[r] - h1[l-1]*p[r-l+1];
}
ull get2(int r,int l){
	return h2[l] - h2[r+1]*p[r-l+1];
}
bool check(int l,int r){
	return get1(l,r) == get2(r,l);
}
int main(){
	int t = 1;
	while(scanf("%s",s1+1),s1[1] != 'E'){
		p[0] = 1;
		int n = strlen(s1+1); 
		for(int i=1;i<=n;i++){
			h1[i] = h1[i-1]*P + s1[i];
			p[i] = p[i-1]*P;
		}
		h2[n+1] = 0;
		for(int i=n;i;i--){
			h2[i] = h2[i+1]*P + s1[i];
		}
		int ans = 1;
		for(int i=1;i<=n;i++){
			int l = 1,r = min(i-1,n-i);
			int ans1 = 0;
			while(l <= r){
				int mid = l + r >> 1;
				if(check(i-mid,i+mid)) ans1 = mid,l = mid+1;
				else r = mid-1;
			}
			ans = max(ans,ans1*2+1);
		}
		for(int i=1;i<=n;i++){
			int l = 1,r = min(i-1,n-i+1);
			int ans1 = 0;
			while(l <= r){
				int mid = l + r >> 1;
				if(check(i-mid,i+mid-1)) ans1 = mid,l = mid+1;
				else r = mid-1;
			}
			ans = max(ans,ans1*2);
		}
		printf("Case %d: %d\n",t++,ans);
	}
	return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

宇智波一打七~

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值