A - Monthly Expense

Farmer John is an astounding accounting wizard and has realized he might run out of money to run the farm. He has already calculated and recorded the exact amount of money (1 ≤ moneyi ≤ 10,000) that he will need to spend each day over the next N (1 ≤ N ≤ 100,000) days.

FJ wants to create a budget for a sequential set of exactly M (1 ≤ M ≤ N) fiscal periods called “fajomonths”. Each of these fajomonths contains a set of 1 or more consecutive days. Every day is contained in exactly one fajomonth.

FJ’s goal is to arrange the fajomonths so as to minimize the expenses of the fajomonth with the highest spending and thus determine his monthly spending limit.

Input
Line 1: Two space-separated integers: N and M
Lines 2…N+1: Line i+1 contains the number of dollars Farmer John spends on the ith day
Output
Line 1: The smallest possible monthly limit Farmer John can afford to live with.

Sample Input
7 5
100
400
300
100
500
101
400

Sample Output
500

Hint
If Farmer John schedules the months so that the first two days are a month, the third and fourth are a month, and the last three are their own months, he spends at most $500 in any month. Any other method of scheduling gives a larger minimum monthly limit.

题目大意:
给出n个数,将其分为至多m段,求和最大的一段值最少为多少,如例子
7 5
100
400
300
100
500
101
400

最优分法是{100,400}、{300,100}、{500}、{101}、{400}

和最大的集合的和为500

解题思路:
二分枚举答案,如例题,

  • 先求答案范围,l =100,r=100+400+300+100+500+101+400=1901;
    则范围为[100,1901}
  • 枚举答案m=(l+r)/2=1000
  • 遍历数组,判断sum+a[i]是否大于1000,大于1000后集合数+1,否则sum+=a[i]
  • 判断集合数是否>m,若大于m,则答案过小了,l = m+1,否则概述恰好是答案,或则过大了,令r=m
  • 一直二分逐渐缩小答案区间,当r<=l时,l就是答案

完整代码:

#include<iostream>
using namespace std;
int main() {
	int n,n2;
	int a[100010];
	cin>>n>>n2;
	int sum=0;
	int ma=0;
	for(int i=0;i<n;i++){
		cin>>a[i];
		sum+=a[i];			//最大范围 
		ma=max(ma,a[i]);	//最小范围 
	}
	int l=ma,r=sum,m;
	while(r>l){	//二分 
		m=(l+r)/2;
		int j=1;
		sum=0;
		for(int i=0;i<n;i++){
			
			if(sum+a[i]<=m){
				sum+=a[i];
			}else{
				sum=a[i];
				j++;
			}
		}
		if(j<=n2){
			r=m;
		}else{
			l=m+1;
		}
	}
	cout<<l;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

旧林墨烟

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值