Monthly Expense

I - Monthly Expense
Time Limit:2000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u

Description

Farmer John is an astounding accounting wizard and has realized he might run out of money to run the farm. He has already calculated and recorded the exact amount of money (1 ≤ moneyi ≤ 10,000) that he will need to spend each day over the next N (1 ≤ N ≤ 100,000) days.

FJ wants to create a budget for a sequential set of exactly M (1 ≤ M ≤ N) fiscal periods called "fajomonths". Each of these fajomonths contains a set of 1 or more consecutive days. Every day is contained in exactly one fajomonth.

FJ's goal is to arrange the fajomonths so as to minimize the expenses of the fajomonth with the highest spending and thus determine his monthly spending limit.

Input

Line 1: Two space-separated integers:  N and  M
Lines 2..  N+1: Line  i+1 contains the number of dollars Farmer John spends on the  ith day

Output

Line 1: The smallest possible monthly limit Farmer John can afford to live with.

Sample Input

7 5
100
400
300
100
500
101
400

Sample Output

500

这个题,一直以来就是个错的还不多......

思想就是符合条件的值一定在所有数据的最大值到和之间。之后利用二分来查找....(就是二分一直是有问题的感觉,然而交上并没问题,当然只有相当磕绊卡的数据才会出错)

#include <iostream>
#include <cstdio>
#include <algorithm>
using namespace std;
int n,m;
int a[100005],high,low,sum;
int judge(int mid)
{
    int i;
    int cnt=1,s=0;
    for(i=0;i<n;++i)
    {
        //if((sum-s)/mid+cnt<m)return 1;
        if(s+a[i]<=mid)s+=a[i];
        else
        {
            cnt++;
            s=a[i];
        }
        if(cnt>m)return 0;
    }
    if(cnt<=m)
        {
            return 1;
        }
}
void solve()
{
    int mid;
    while(low<=high)
    {
        mid=(low+high)/2;
        if(judge(mid))
        {
            high=mid-1;
        }
        else low=mid+1;
    }
    printf("%d\n",mid);
}
int main()
{
    while(~scanf("%d%d",&n,&m))
    {
        int i;
        low=high=0;
        for(i=0;i<n;++i)
        {
            scanf("%d",&a[i]);
            low=max(low,a[i]);
            high+=a[i];
        }
        sum=high;
        solve();
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值