K - Doing Homework again (贪心)

7 篇文章 0 订阅

Ignatius has just come back school from the 30th ACM/ICPC. Now he has a lot of homework to do. Every teacher gives him a deadline of handing in the homework. If Ignatius hands in the homework after the deadline, the teacher will reduce his score of the final test. And now we assume that doing everyone homework always takes one day. So Ignatius wants you to help him to arrange the order of doing homework to minimize the reduced score.
Input
The input contains several test cases. The first line of the input is a single integer T that is the number of test cases. T test cases follow.
Each test case start with a positive integer N(1<=N<=1000) which indicate the number of homework… Then 2 lines follow. The first line contains N integers that indicate the deadlines of the subjects, and the next line contains N integers that indicate the reduced scores.
Output
For each test case, you should output the smallest total reduced score, one line per test case.

Sample Input
3
3
3 3 3
10 5 1
3
1 3 1
6 2 3
7
1 4 6 4 2 4 3
3 2 1 7 6 5 4

Sample Output
0
3
5

题目大意:
每个测试样例第一行给出作业的截止时间,第二行给出分数值,每做一个作业需要一天时间,没做出来的作业就扣除相应分数,求最少扣分为多少

解题思路:
贪心思想,优先考虑分数最高的作业,把作业尽可能地安排在截止日期之前做完,如果当天有安排了就考虑前一天。如果不能安排下了就无法完成

完整代码:

#include <iostream>
#include<algorithm>
using namespace std;
struct node{
	int a,b;
}c[1010];

bool cmp(node e,node f){
	return e.b>f.b;
}

int main()
{
	int t,n;
	cin>>t;
	while(t--){
		int g[1010]{0},sum=0;
		cin>>n;
		for(int i=0;i<n;i++){
			cin>>c[i].a;
		}
		for(int i=0;i<n;i++){
			cin>>c[i].b;
		}
		sort(c,c+n,cmp);	//排序 
		for(int i=0;i<n;i++){
			int flag=1;
			int d=c[i].a;
			while(d--){
				if(g[d]==0){
					g[d]=1;
					flag=0;
					break;
				}
			}
			if(flag){		//无法完成 
				sum+=c[i].b;
			}
		}
		cout<<sum<<endl;
	}
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

旧林墨烟

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值