G - Doing Homework again

Ignatius has just come back school from the 30th ACM/ICPC. Now he has a lot of homework to do. Every teacher gives him a deadline of handing in the homework. If Ignatius hands in the homework after the deadline, the teacher will reduce his score of the final test. And now we assume that doing everyone homework always takes one day. So Ignatius wants you to help him to arrange the order of doing homework to minimize the reduced score.

Input

The input contains several test cases. The first line of the input is a single integer T that is the number of test cases. T test cases follow. 
Each test case start with a positive integer N(1<=N<=1000) which indicate the number of homework.. Then 2 lines follow. The first line contains N integers that indicate the deadlines of the subjects, and the next line contains N integers that indicate the reduced scores. 

Output

For each test case, you should output the smallest total reduced score, one line per test case. 

Sample Input

3
3
3 3 3
10 5 1
3
1 3 1
6 2 3
7
1 4 6 4 2 4 3
3 2 1 7 6 5 4

Sample Output

0
3
5

题意:给一个t,代表有t组测试数据,然后是有n项家庭作业,第一行有n个整数,代表n项家庭作业上交的最晚时间,第二行有n个整数,代表上交一项作业获得分数。问最少会失去多少分。

题解:这是一道贪心题,应给先把分数从大到小排序,然后再在要求的那一天写作业,如果这一天已经被占用,则找这一天你之前的一天写作业,如果都被占用,则把分数加起来,这就是失去的最少分数。

#include<stdio.h>
#include<string.h>
#include<algorithm>
int book[10000];
struct node
{
    int d,f;
}s[1005];
using namespace std;
bool cmp(node x,node y)
{
    if(x.f==y.f)
        return x.d<y.d;
    return x.f>y.f;
}
int main()
{
    int t,n,i,j,sum;
    scanf("%d",&t);
    while(t--)
    {
        sum=0;
        memset(book,0,sizeof(book));
        scanf("%d",&n);
        for(i=0;i<n;i++)
        {
            scanf("%d",&s[i].d);
        }
        for(i=0;i<n;i++)
        {
            scanf("%d",&s[i].f);
        }
        sort(s,s+n,cmp);
        for(i=0;i<n;i++)
        {
            for(j=s[i].d;j>0;j--)
            {
                if(book[j]==0)
                {
                    book[j]=1;
                    break;
                }
            }
            if(j==0)
                sum+=s[i].f;
        }
        printf("%d\n",sum);
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值