Kattis-Autori

文章讨论了科学发现通常以其发现者姓氏命名的惯例,如RSA加密算法和KMP字符串搜索算法。它提出了一个问题,即在同一份文档中混合使用长形式(如Knuth-Morris-Pratt)和短形式(如KMP)的不一致性,并要求编写一个程序将长形式转换为短形式。给定的C++代码示例实现了这一转换功能。
摘要由CSDN通过智能技术生成

题目所述基本内容

Great scientific discoveries are often named by the last names of scientists that made them. For example, the most popular asymmetric cryptography system, RSA was discovered by Rivest, Shamir and Adleman. Another notable example is the Knuth-Morris-Pratt algorithm, named by Knuth, Morris and Pratt.

Scientific papers reference earlier works a lot and it’s not uncommon for one document to use two different naming conventions: the short variation (e.g. KMP) using only the first letters of authors last names and the long variation (e.g. Knuth-Morris-Pratt) using complete last names separated by hyphens.

We find mixing two conventions in one paper to be aesthetically unpleasing and would like you to write a program that will transform long variations into short.

输入输出样例

Input

The first and only line of input will contain at most 100 characters, uppercase and lowercase letters of the English alphabet and hyphen (‘-’ ASCII 45). The first character will always be an uppercase letter. Hyphens will always be followed by an uppercase letter. All other characters will be lowercase letters.

Output

The first and only line of output should contain the appropriate short variation.

Sample Input 1Sample Output 1
Knuth-Morris-Pratt
KMP
Sample Input 2Sample Output 2
Mirko-Slavko
MS
Sample Input 3Sample Output 3
Pasko-Patak
PP

代码

#include<iostream>
#include<string>
#include<vector>
using namespace std;
int main() {
	vector<char>result;
	string str;
	cin >> str;
	result.push_back(str[0]);
	for (int i = 1; i < str.size(); i++) {
		if (str[i]=='-') {
			result.push_back(str[i + 1]);
		}
	}
	for (int i = 0; i < result.size(); i++) {
		cout << result[i];
	}
	return 0;
}

结束语

好兄弟好兄弟,留下你的关注和点赞,666走一波!!!!!

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

做一个AC梦

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值