线段数组

可参考的大佬

const int maxn=10001;
int tree[maxn],a[maxn];
int lowbit(int x){
	return (x&(-x));
}
void add(int i,int k){
	while(i<=n){
		tree[x]+=k;
		x+=lowbit(x);
	}
}
int sum(int x){
	int sum=0;
	while(x>0){
		sum+=tree[x];
		x-=lowbit(x);
	}
	return sum;
}

以poj2182Lost Cows为例
Description
N (2 <= N <= 8,000) cows have unique brands in the range 1…N. In a spectacular display of poor judgment, they visited the neighborhood ‘watering hole’ and drank a few too many beers before dinner. When it was time to line up for their evening meal, they did not line up in the required ascending numerical order of their brands.
Regrettably, FJ does not have a way to sort them. Furthermore, he’s not very good at observing problems. Instead of writing down each cow’s brand, he determined a rather silly statistic: For each cow in line, he knows the number of cows that precede that cow in line that do, in fact, have smaller brands than that cow.
Given this data, tell FJ the exact ordering of the cows.

Input

  • Line 1: A single integer, N
  • Lines 2…N: These N-1 lines describe the number of cows that precede a given cow in line and have brands smaller than that cow. Of course, no cows precede the first cow in line, so she is not listed. Line 2 of the input describes the number of preceding cows whose brands are smaller than the cow in slot #2; line 3 describes the number of preceding cows whose brands are smaller than the cow in slot #3; and so on.

Output

  • Lines 1…N: Each of the N lines of output tells the brand of a cow in line. Line #1 of the output tells the brand of the first cow in line; line 2 tells the brand of the second cow; and so on.

Sample Input

5
1
2
1
0

Sample Output
2
4
5
3
1

题意:N头奶牛排队,它们的身高为1~n,知道每头牛前面有多少头比自己矮,求每头牛的身高。

分析:不难发现要从后往前确定每头牛的身高,这样每头牛的身高就是1~n中没被选过的第a[i]+1大的数(因为有a[i]头比自己矮),那么我们只需用树状数组维护一个01序列,没选过的数标为1,每次查询时二分mid,通过树状数组ask(mid)计算前mid个数有几个为1即没被选过的,直到找到a[i]+1。这里题目较为特殊不需要借助add进行初始化,因为每一个的数字都是1,所以tree[i]=lowbit(i),最后查找时,通过对半查找,找到Ax的时候赋为0,然后用add更新数组。

#include <cstdio>
#define N 100005
using namespace std;
int c[N],a[N],b[N],n;
void add(int x, int val)
{
    while (x <= n)
    {
        c[x]+=val;
        x+=x&(-x);
    }
}
int count(int x)
{
    int s = 0;
    while (x > 0)
    {
        s+=c[x];
        x-=x&-x;
    }
    return s;
}
int find(int x)
{
    int l = 1, r = n;
    int p;
    while (l <= r)
    {
        int mid = (l + r) / 2;
        if (count(mid) >= x)
        {
            p = mid;
            r = mid - 1;
        }
        else l = mid + 1;
    }
    return p;
}
int main()
{
    scanf("%d", &n);
    add(1, 1);
    for (int i = 2; i <= n; i++)
    {
        scanf("%d", &a[i]);
        add(i ,1);
    }   for (int i = n; i >= 1; i--)
    {
        int pos = find(a[i] + 1);
        b[i] = pos;
        add(pos, -1);
    }
    for (int i = 1; i <= n; i++)
        printf("%d\n", b[i]);
}

以下是可以继续学习的例题 poj2299

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值