进位与借位(虚函数和多态)
题目描述
某小学二年级的数学老师在教学生整数加减法运算时发现:班上的同学可以分成三类,第一类可以正确地完成加减法运算(GroupA);第二类可以正确地完成加法运算,但对于减法运算来说,总是忘记借位的处理(GroupB);第三类总是忘记加法的进位,也总是忘记减法的借位(GroupC)。(提示:小学二年级还没学负数。)
现在请模拟当老师在课堂提问某位同学时,同学会给出的回答。
实现时请基于下面的基类框架:
class Group
{
public:
virtual int add(int x, int y)=0;//输出加法的运算结果
virtual int sub(int x, int y)=0;//输出减法的运算结果
}
构建出GroupA, GroupB和GroupC三个派出类:
并编写主函数,要求主函数中有一个基类Group指针,通过该指针统一地进行add和sub运算。
输入
第一行表示测试次数。从第二行开始,每个测试用例占一行,每行数据意义如下:学生类别(1为第一类学生,2为第二类学生,3为第三类学生)、第一个数、第二个数。
输出
运算后的结果
示例输入
3
1 79+81
2 81-79
3 183+69
示例输出
160
12
142
#include<iostream>
#include<iomanip>
#include<string>
using namespace std;
class Group{
public:
Group()
{
}
virtual int add(int x,int y)=0;
virtual int sub(int x,int y)=0;
protected:
};
class GroupA:public Group{
public:
GroupA()
{
}
virtual int add(int x,int y)
{
int sum;
sum=x+y;
return sum;
}
virtual int sub(int x,int y)
{
int sum;
sum=x-y;
return sum;
}
protected:
};
class GroupB:public Group{
public:
GroupB()
{
}
virtual int add(int x,int y)
{
int sum;
sum=x+y;
return sum;
}
virtual int sub(int x,int y)
{
int a1,b1,c1,a2,b2,c2,a3,b3,c3;
a1=x/100;
b1=x%100/10;
c1=x%10;
a2=y/100;
b2=y%100/10;
c2=y%10;
if(a1<a2&&a1!=0)
{
a1+=10;
a3=a1-a2;
}
else
a3=a1-a2;
if(b1<b2)
{
b1+=10;
b3=b1-b2;
}
else
b3=b1-b2;
if(c1<c2)
{
c1+=10;
c3=c1-c2;
}
else
c3=c1-c2;
int sum;
sum=a3*100+b3*10+c3;
return sum;
}
protected:
};
class GroupC:public Group{
public:
GroupC()
{
}
virtual int add(int x,int y)
{
int a1,b1,c1,a2,b2,c2,a3,b3,c3;
a1=x/100;
b1=x%100/10;
c1=x%10;
a2=y/100;
b2=y%100/10;
c2=y%10;
a3=(a1+a2)%10;
b3=(b1+b2)%10;
c3=(c1+c2)%10;
int sum;
sum=a3*100+b3*10+c3;
return sum;
}
virtual int sub(int x,int y)
{
int a1,b1,c1,a2,b2,c2,a3,b3,c3;
a1=x/100;
b1=x%100/10;
c1=x%10;
a2=y/100;
b2=y%100/10;
c2=y%10;
if(a1<a2&&a1!=0)
{
a1+=10;
a3=a1-a2;
}
else
a3=a1-a2;
if(b1<b2)
{
b1+=10;
b3=b1-b2;
}
else
b3=b1-b2;
if(c1<c2)
{
c1+=10;
c3=c1-c2;
}
else
c3=c1-c2;
int sum;
sum=a3*100+b3*10+c3;
return sum;
}
protected:
};
int main()
{
int i,t;
int type;
int x,y;
char ch;
cin>>t;
Group *Group1;
int sum;
for(i=0;i<t;i++)
{
cin>>type;
if(type==1)
{
cin>>x>>ch>>y;
GroupA GroupA1;
Group1=&GroupA1;
if(ch=='+')
sum=Group1->add(x,y);
else if(ch=='-')
sum=Group1->sub(x,y);
}
else if(type==2)
{
cin>>x>>ch>>y;
GroupB GroupB1;
Group1=&GroupB1;
if(ch=='+')
sum=Group1->add(x,y);
else if(ch=='-')
sum=Group1->sub(x,y);
}
else if(type==3)
{
cin>>x>>ch>>y;
GroupC GroupC1;
Group1=&GroupC1;
if(ch=='+')
sum=Group1->add(x,y);
else if(ch=='-')
sum=Group1->sub(x,y);
}
cout<<sum<<endl;
}
return 0;
}