7-111 吃鱼还是吃肉

fish.JPG

肉.JPG

国家给出了 8 岁男宝宝的标准身高为 130 厘米、标准体重为 27 公斤;8 岁女宝宝的标准身高为 129 厘米、标准体重为 25 公斤。

现在你要根据小宝宝的身高体重,给出补充营养的建议。

输入格式:

输入在第一行给出一个不超过 10 的正整数 N,随后 N 行,每行给出一位宝宝的身体数据:

性别 身高 体重

其中性别是 1 表示男生,0 表示女生。身高体重都是不超过 200 的正整数。

输出格式:

对于每一位宝宝,在一行中给出你的建议:

  • 如果太矮了,输出:duo chi yu!(多吃鱼);
  • 如果太瘦了,输出:duo chi rou!(多吃肉);
  • 如果正标准,输出:wan mei!(完美);
  • 如果太高了,输出:ni li hai!(你厉害);
  • 如果太胖了,输出:shao chi rou!(少吃肉)。

先评价身高,再评价体重。两句话之间要有 1 个空格。

输入样例:

4
0 130 23
1 129 27
1 130 30
0 128 27

结尾无空行

输出样例:

ni li hai! duo chi rou!
duo chi yu! wan mei!
wan mei! shao chi rou!
duo chi yu! shao chi rou!

结尾无空行

代码:

#include<stdio.h>
#include<string.h>
struct ren
{
    int xo;
    int sg;
    int tz;
};
int main()
{
    int n,j,i,k,t=0;
    scanf("%d",&n);
    struct ren std[n];
    for(i=0;i<n;i++)
    {
        scanf("%d %d %d",&std[i].xo,&std[i].sg,&std[i].tz);
    }
    for(i=0;i<n;i++)
    {
        if(std[i].xo==1)
        {
            if(std[i].sg<130)
            {
                printf("duo chi yu! ");
            }
            if(std[i].sg==130)
            {
                printf("wan mei! ");
            }
            if(std[i].sg>130)
            {
                printf("ni li hai! ");
            }
            if(std[i].tz>27)
            {
                printf("shao chi rou!");
            }
            if(std[i].tz==27)
            {
                printf("wan mei!");
            }
            if(std[i].tz<27)
            {
                printf("duo chi rou!");
            }
        }
        else
        {
            if(std[i].sg<129)
            {
                printf("duo chi yu! ");
            }
            if(std[i].sg==129)
            {
                printf("wan mei! ");
            }
            if(std[i].sg>129)
            {
                printf("ni li hai! ");
            }
            if(std[i].tz>25)
            {
                printf("shao chi rou!");
            }
            if(std[i].tz==25)
            {
                printf("wan mei!");
            }
            if(std[i].tz<25)
            {
                printf("duo chi rou!");
            }
        }
        printf("\n");
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

信仰12800

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值