1059 Prime Factors

Given any positive integer N, you are supposed to find all of its prime factors, and write them in the format N = p1​k1​×p2​k2​×⋯×pm​km​.

Input Specification:

Each input file contains one test case which gives a positive integer N in the range of long int.

Output Specification:

Factor N in the format N = p1​^k1​*p2​^k2​**pm​^km​, where pi​'s are prime factors of N in increasing order, and the exponent ki​ is the number of pi​ -- hence when there is only one pi​, ki​ is 1 and must NOT be printed out.

Sample Input:

97532468

Sample Output:

97532468=2^2*11*17*101*1291

线性筛素数建立素数表: 

#include <iostream>
#include <bitset>
using namespace std;
long long int prime[10000010];

bitset<100000010>b;//不是素数为1 是素数为0
int main() {
	long long int n, cnt = 0, k;
	b[1] = 1;
	for (int i = 2; i <= 100009; i++) {
		if (!b[i]) {
			prime[++cnt] = i;
		}
		for (int j = 1; j <= cnt && i * prime[j] <= 100009; j++) {
			b[i * prime[j]] = 1;
			if (i % prime[j] == 0) {
				break;
			}
		}
	}
	cin >> n;
	cout << n << '=';
	if (n == 1) {
		cout << 1;
		return 0;
	}
	while (n != 1) {
		bool flag = 0;
		for (int i = 1; i <= cnt; i++) {
			flag = 0;
			k = 0;
			while (n % prime[i] == 0) {
				k++;
				n /= prime[i];
				flag = 1;
			}
			if (flag) {
				cout << prime[i];
				if (k > 1) {
					cout << '^' << k;
				}
				if (n > 1) {
					cout << '*';
				}
			}
		}
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值