(甲)1059 Prime Factors

Given any positive integer N, you are supposed to find all of its prime factors, and write them in the format N = p​1​​​k​1​​​​×p​2​​​k​2​​​​×⋯×p​m​​​k​m​​​​.

Input Specification:

Each input file contains one test case which gives a positive integer N in the range of long int.

Output Specification:

Factor N in the format N = p​1​​^k​1​​*p​2​​^k​2​​**p​m​​^k​m​​, where p​i​​'s are prime factors of N in increasing order, and the exponent k​i​​ is the number of p​i​​ -- hence when there is only one p​i​​, k​i​​ is 1 and must NOT be printed out.

Sample Input:

97532468

Sample Output:

97532468=2^2*11*17*101*1291

key: 

#include <iostream>
#include <cmath>
#define maxn 100001
using namespace std;
long long prime[maxn],num=0;  //prime数组用于记录素数 
bool panduan(int m)            //判断素数
{
	int ok=0;
	for(int i=2;i<=sqrt(m);i++)
	{
		if(m%i==0)
		{
			return 0;
		}
	}
    return 1;
}
void Find_Prime()
{
	for(int i=2;i<maxn;i++)
	{
		if(panduan(i))
		{
			prime[num++]=i;
		}
	}
}
int main()
{
	Find_Prime();
	long long n,t=0;
	cin>>n;
	cout<<n<<"=";
	if(panduan(n)) cout<<n;  //如果是素数直接输出(这里把1也直接输出了)
	else
	while(n!=1)
	{
		int num=0,ok=0;
		while(n%prime[t]==0)
		{
			ok=1;
			num++;   //记录次数
			n/=prime[t];
		}
		if(ok)
		{
		cout<<prime[t];
		if(num>1) cout<<"^"<<num;
		if(n!=1) cout<<"*";}
		t++;
	}
	return 0;
 } 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值