1110. Complete Binary Tree

1110. Complete Binary Tree (25)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

Given a tree, you are supposed to tell if it is a complete binary tree.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<=20) which is the total number of nodes in the tree -- and hence the nodes are numbered from 0 to N-1. Then N lines follow, each corresponds to a node, and gives the indices of the left and right children of the node. If the child does not exist, a "-" will be put at the position. Any pair of children are separated by a space.

Output Specification:

For each case, print in one line "YES" and the index of the last node if the tree is a complete binary tree, or "NO" and the index of the root if not. There must be exactly one space separating the word and the number.

Sample Input 1:
9
7 8
- -
- -
- -
0 1
2 3
4 5
- -
- -
Sample Output 1:
YES 8
Sample Input 2:
8
- -
4 5
0 6
- -
2 3
- 7
- -
- -
Sample Output 2:
NO 1
先建树,把位置记下来,根节点的位置为0。
然后遍历一下,看看位置有没有超过n,顺便记一下位置为n-1的值。
#include<iostream>
#include<algorithm>
#include<vector>
#include<string>

using namespace std;

typedef struct node
{
	int pos;
	int l,r;
};
node t[20];
bool f[20];

void buildtree(int root,int pos)
{
	t[root].pos=pos;
	if(t[root].l!=-1)
		buildtree(t[root].l,2*pos+1);
	if(t[root].r!=-1)
		buildtree(t[root].r,2*pos+2);
}

int s2i(string s)
{
	if(s=="-")
		return -1;
	int num=0;
	for(int i=0;i<s.size();i++)
		num=num*10+s[i]-'0';
	f[num]=true;
	return num;
}
int main()
{
	int n;
	cin>>n;
	for(int i=0;i<n;i++)
		f[i]=false;
	for(int i=0;i<n;i++)
	{
		string l,r;
		cin>>l>>r;
		t[i].l=s2i(l);
		t[i].r=s2i(r);
	}
	int root;
	for(int i=0;i<n;i++)
		if(f[i]==false)
			root=i;
	buildtree(root,0);
	int rear;
	for(int i=0;i<n;i++)
	{
		if(!(t[i].pos>=0&&t[i].pos<n))
		{
			cout<<"NO"<<" "<<root;
			return 0;
		}
		else if(t[i].pos==n-1)
			rear=i;
	}
	cout<<"YES"<<" "<<rear;
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值