1114 Family Property

This time, you are supposed to help us collect the data for family-owned property. Given each person's family members, and the estate(房产)info under his/her own name, we need to know the size of each family, and the average area and number of sets of their real estate.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤1000). Then N lines follow, each gives the infomation of a person who owns estate in the format:

ID Father Mother k Child1​⋯Childk​ Mestate​ Area

where ID is a unique 4-digit identification number for each person; Father and Mother are the ID's of this person's parents (if a parent has passed away, -1 will be given instead); k (0≤k≤5) is the number of children of this person; Childi​'s are the ID's of his/her children; Mestate​ is the total number of sets of the real estate under his/her name; and Area is the total area of his/her estate.

Output Specification:

For each case, first print in a line the number of families (all the people that are related directly or indirectly are considered in the same family). Then output the family info in the format:

ID M AVGsets​ AVGarea​

where ID is the smallest ID in the family; M is the total number of family members; AVGsets​ is the average number of sets of their real estate; and AVGarea​ is the average area. The average numbers must be accurate up to 3 decimal places. The families must be given in descending order of their average areas, and in ascending order of the ID's if there is a tie.

Sample Input:

10
6666 5551 5552 1 7777 1 100
1234 5678 9012 1 0002 2 300
8888 -1 -1 0 1 1000
2468 0001 0004 1 2222 1 500
7777 6666 -1 0 2 300
3721 -1 -1 1 2333 2 150
9012 -1 -1 3 1236 1235 1234 1 100
1235 5678 9012 0 1 50
2222 1236 2468 2 6661 6662 1 300
2333 -1 3721 3 6661 6662 6663 1 100

Sample Output:

3
8888 1 1.000 1000.000
0001 15 0.600 100.000
5551 4 0.750 100.000

注意:不是所有人的信息都会给出,有人只是在人的具体信息中的父母或者孩子出现编号,建图时可能会出现重复边的情况,使用vis数组记录可以避免重复访问,同时使用另一个数组记录所有出现过的编号,用于后面的统计;然后相当于数有几个连通图,计算每个连通图中结点个数等,如果图是联通的,那么从任意一个结点开始遍历都能遍历完一张图,使用vis数组记录访问历史。

#include <iostream>
#include <algorithm>
#include <iomanip>
#include <vector>
#include <cstring>
using namespace std;
int n, ans, cnt;
int c[10010];
bool vis[10010];
vector<int>g[10010];

struct Peo {
	int fa, mo, k, mes, area;
	bool flag;
	int child[10010];
} a[10010];

struct Fam {
	int id, sum;
	double avgs, avga;
} b[10010];

bool cmp(Fam f1, Fam f2) {
	return f1.avga == f2.avga ? f1.id<f2.id: f1.avga >f2.avga;
}

void dfs(int x) {
	if (a[x].flag) {
		b[ans].avga += a[x].area;
		b[ans].avgs += a[x].mes;
	}
	b[ans].sum++;
	b[ans].id = min(b[ans].id, x);
	for (int i = 0; i < g[x].size(); i++) {
		if (!vis[g[x][i]]) {
			vis[g[x][i]] = 1;
			dfs(g[x][i]);
		}
	}
}

int main() {
	cin >> n;
	int id;
	for (int i = 0; i < n; i++) {
		cin >> id;
		if (!vis[id]) {
			vis[id] = 1;
			c[cnt++] = id;
		}
		a[id].flag = 1;
		cin >> a[id].fa >> a[id].mo >> a[id].k;
		if (a[id].fa != -1) {
			g[id].push_back(a[id].fa);
			g[a[id].fa].push_back(id);
			if (!vis[a[id].fa]) {
				vis[a[id].fa] = 1;
				c[cnt++] = a[id].fa;
			}
		}
		if (a[id].mo != -1) {
			g[id].push_back(a[id].mo);
			g[a[id].mo].push_back(id);
			if (!vis[a[id].mo]) {
				vis[a[id].mo] = 1;
				c[cnt++] = a[id].mo;
			}
		}
		for (int j = 0; j < a[id].k; j++) {
			cin >> a[id].child[j];
			g[id].push_back(a[id].child[j]);
			g[a[id].child[j]].push_back(id);
			if (!vis[a[id].child[j]]) {
				vis[a[id].child[j]] = 1;
				c[cnt++] = a[id].child[j];
			}
		}
		cin >> a[id].mes >> a[id].area;
	}
	memset(vis, 0, sizeof(vis));
	for (int i = 0; i < cnt; i++) {
		if (!vis[c[i]]) {
			vis[c[i]] = 1;
			b[ans].id = 10010;
			dfs(c[i]);
			ans++;
		}
	}
	for (int i = 0; i < ans; i++) {
		b[i].avga /= (1.0 * b[i].sum);
		b[i].avgs /= (1.0 * b[i].sum);
	}
	sort(b, b + ans, cmp);
	cout << ans << endl;
	for (int i = 0; i < ans; i++) {
		cout << setw(4) << setfill('0') << b[i].id << ' ' << b[i].sum << ' ' << setprecision(
		         3) << fixed << b[i].avgs << ' ' << setprecision(
		         3) << fixed << b[i].avga << endl;
	}
	return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值