1114 Family Property (25 分)

1114 Family Property (25 分)

This time, you are supposed to help us collect the data for family-owned property. Given each person's family members, and the estate(房产)info under his/her own name, we need to know the size of each family, and the average area and number of sets of their real estate.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤1000). Then N lines follow, each gives the infomation of a person who owns estate in the format:

ID Father Mother k Child​1​​⋯Child​k​​ M​estate​​ Area

where ID is a unique 4-digit identification number for each person; Father and Mother are the ID's of this person's parents (if a parent has passed away, -1 will be given instead); k (0≤k≤5) is the number of children of this person; Child​i​​'s are the ID's of his/her children; M​estate​​ is the total number of sets of the real estate under his/her name; and Area is the total area of his/her estate.

Output Specification:

For each case, first print in a line the number of families (all the people that are related directly or indirectly are considered in the same family). Then output the family info in the format:

ID M AVG​sets​​ AVG​area​​

where ID is the smallest ID in the family; M is the total number of family members; AVG​sets​​ is the average number of sets of their real estate; and AVG​area​​ is the average area. The average numbers must be accurate up to 3 decimal places. The families must be given in descending order of their average areas, and in ascending order of the ID's if there is a tie.

Sample Input:

10
6666 5551 5552 1 7777 1 100
1234 5678 9012 1 0002 2 300
8888 -1 -1 0 1 1000
2468 0001 0004 1 2222 1 500
7777 6666 -1 0 2 300
3721 -1 -1 1 2333 2 150
9012 -1 -1 3 1236 1235 1234 1 100
1235 5678 9012 0 1 50
2222 1236 2468 2 6661 6662 1 300
2333 -1 3721 3 6661 6662 6663 1 100

Sample Output:

3
8888 1 1.000 1000.000
0001 15 0.600 100.000
5551 4 0.750 100.000

输出就是  每个集合中id最小的, 总共多少套房子, 平均每人的房子数量和平均每人的房子面积,

先按照平均每人的房子面积从大到小输出 如果相等的话 那么就按照id从小到大输出

思路:并查集的题 ,这题水 就是处理有一点点烦

代码:

#include<bits/stdc++.h>
using namespace std;
struct node{
	int upset,squ,cnt;
	node(){
		cnt = 1;
		upset = 0;
		squ = 0;
	}
}s[10005];
struct GG{
	double cnt,upset,squ;
	int id;
};
int pre[10005];
bool flag[10005]; //刚开始不都是false  如果有出现就true 
int find(int x){
	if( x == pre[x])
		return x;
	return pre[x] = find(pre[x]);
}
void merge(int x, int y){
	int fx = find(x);
	int fy = find(y);
	if(fx > fy)
		pre[fx] = fy;
	else if(fx < fy)
		pre[fy] = fx; 
	return;
}
bool cmp(GG a, GG b){
	if(a.squ != b.squ)
		return a.squ > b.squ;
	else 
		return a.id < b.id; 
}
int main(){
	int n;
	scanf("%d", &n);
	for(int i = 1; i <= 10000; i ++)
		pre[i] = i;
	int me, fa, mo, cnt, child;
	for(int i = 1; i <= n; i ++)
	{
		scanf("%d %d %d",&me,&fa,&mo);
		flag[me] = true; 
		if(fa != -1)
		{
			merge(me, fa);
			flag[fa] = true;
		}	
		if(mo != -1)
		{
			merge(me, mo);
			flag[mo] = true;
		}	
		scanf("%d",&cnt);
		for(int j = 1; j <= cnt; j ++ )
		{
			scanf("%d",&child);	
			merge(child, me);
			flag[child] = true;
		}	
		scanf("%d %d",&s[me].upset, &s[me].squ);
	}
	set<int>st;
	for(int i = 10000; i >= 0; i--)  //这边wa了第四个测试点因为0---10000  我写成1----10000
	{
		if(flag[i] == true)
		{
			int x = find(i);//找到它的祖先
			st.insert(x);
			if(x != i)
			{
				s[x].cnt += s[i].cnt;
				s[x].squ += s[i].squ;
				s[x].upset += s[i].upset;	
			}
		}
	}
	set<int>::iterator it = st.begin();
	vector<GG>vec;
	while(it!=st.end())
	{
		GG gg;
		gg.id = *it;
		gg.cnt = s[*it].cnt;
		gg.squ =s[*it].squ * 1.0 / s[*it].cnt * 1.0;
		gg.upset = s[*it].upset * 1.0 / s[*it].cnt * 1.0;
		vec.push_back(gg);
		it++;
	}
	sort(vec.begin(),vec.end(),cmp);
	printf("%d\n",vec.size());
	for(int i = 0 ; i < vec.size(); i++)
		printf("%04d %.0lf %.3lf %.3lf\n",vec[i].id, vec[i].cnt,vec[i].upset, vec[i].squ);
	return 0;
} 

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值