1135 Is It A Red-Black Tree

There is a kind of balanced binary search tree named red-black tree in the data structure. It has the following 5 properties:

  • (1) Every node is either red or black.
  • (2) The root is black.
  • (3) Every leaf (NULL) is black.
  • (4) If a node is red, then both its children are black.
  • (5) For each node, all simple paths from the node to descendant leaves contain the same number of black nodes.

For example, the tree in Figure 1 is a red-black tree, while the ones in Figure 2 and 3 are not.

Figure 1Figure 2Figure 3

For each given binary search tree, you are supposed to tell if it is a legal red-black tree.

Input Specification:

Each input file contains several test cases. The first line gives a positive integer K (≤30) which is the total number of cases. For each case, the first line gives a positive integer N (≤30), the total number of nodes in the binary tree. The second line gives the preorder traversal sequence of the tree. While all the keys in a tree are positive integers, we use negative signs to represent red nodes. All the numbers in a line are separated by a space. The sample input cases correspond to the trees shown in Figure 1, 2 and 3.

Output Specification:

For each test case, print in a line "Yes" if the given tree is a red-black tree, or "No" if not.

Sample Input:

3
9
7 -2 1 5 -4 -11 8 14 -15
9
11 -2 1 -7 5 -4 8 14 -15
8
10 -7 5 -6 8 15 -11 17

Sample Output:

Yes
No
No
#include <iostream>
#include <cmath>
using namespace std;

struct node {
	int val;
	node *left;
	node *right;
};
int k, n, x, cnt;
bool flag;

node *build(node *r, int val) {
	if (r == NULL) {
		r = new node();
		r->val = val;
		r->left = r->right = NULL;
	} else if (abs(val) < abs(r->val)) {
		r->left = build(r->left, val);
	} else {
		r->right = build(r->right, val);
	}
	return r;
}

void checkcolor(node *r) {
	if (flag) {
		return;
	}
	if (r->val < 0) {
		if (r->left && r->left->val < 0) {
			flag = 1;
			return;
		}
		if (r->right && r->right->val < 0) {
			flag = 1;
			return;
		}
	}
	if (r->left) {
		checkcolor(r->left);
	}
	if (r->right) {
		checkcolor(r->right);
	}
}

void checknum(node *r, int c) {
	if (flag) {
		return;
	}
	if (r == NULL) {
		c++;
		if (cnt == -1) {
			cnt = c;
		} else {
			if (cnt != c) {
				flag = 1;
				return;
			}
		}
	} else {
		if (r->val > 0) {
			c++;
		}
		checknum(r->left, c);
		checknum(r->right, c);
	}
}

int main() {
	cin >> k;
	while (k--) {
		cin >> n;
		node *root = NULL;
		flag = 0;
		cnt = -1;
		for (int i = 0; i < n; i++) {
			cin >> x;
			root = build(root, x);
		}
		if (root->val < 0) {
			cout << "No" << endl;
			continue;
		}
		checkcolor(root);
		if (flag) {
			cout << "No" << endl;
			continue;
		}
		checknum(root, 1);
		if (flag) {
			cout << "No" << endl;
			continue;
		}
		cout << "Yes" << endl;
	}
	return 0;
}

参考博客:1135 Is It A Red-Black Tree (30分)_一只小蒟蒻的博客-CSDN博客

1135. Is It A Red-Black Tree (30)-PAT甲级真题_柳婼的博客-CSDN博客 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值