MPLS-

在这里插入图片描述
根据题目要求搭建出拓扑:
在这里插入图片描述

1.首先打通公网部分

[r2]int l 0
[r2-LoopBack0]ip ad 2.2.2.2 24
[r2-LoopBack0]int g 0/0/0
[r2-GigabitEthernet0/0/0]ip ad 23.1.1.1 24
[r3]int l 0
[r3-LoopBack0]ip ad  3.3.3.3 24
[r3-LoopBack0]int g 0/0/1
[r3-GigabitEthernet0/0/1]ip ad 23.1.1.2 24
[r3-GigabitEthernet0/0/1]int g 0/0/0
[r3-GigabitEthernet0/0/0]ip ad 34.1.1.1 24
[r4]int l 0
[r4-LoopBack0]ip ad 4.4.4.4 24
[r4-LoopBack0]int  g 0/0/1
[r4-GigabitEthernet0/0/1]ip ad 34.1.1.2 24
[r4-GigabitEthernet0/0/1]int g 0/0/2
[r4-GigabitEthernet0/0/2]ip ad 47.1.1.1 24
[r7]int g 0/0/2
[r7-GigabitEthernet0/0/2]ip ad 47.1.1.2 24
[r2]ospf 1 router-id 2.2.2.2
[r2-ospf-1]area 0
[r2-ospf-1-area-0.0.0.0]network 2.2.2.2 0.0.0.0
[r2-ospf-1-area-0.0.0.0]network 23.1.1.1 0.0.0.0
[r3]ospf 1 router-id 3.3.3.3
[r3-ospf-1]area 0
[r3-ospf-1-area-0.0.0.0]network 3.3.3.3 0.0.0.0	
[r3-ospf-1-area-0.0.0.0]network 23.1.1.2 0.0.0.0
[r3-ospf-1-area-0.0.0.0]network 34.1.1.1 0.0.0.0
[r4]ospf 1 router-id  4.4.4.4
[r4-ospf-1]area 0
[r4-ospf-1-area-0.0.0.0]network 4.4.4.4 0.0.0.0.0
[r4-ospf-1-area-0.0.0.0]network 34.1.1.2 0.0.0.0
[r4-ospf-1]silent-interface GigabitEthernet 0/0/2
[r7]ip route-static 0.0.0.0 0.0.0.0 47.1.1.1

2.开启MPLS

[r2]mpls lsr-id 2.2.2.2
[r2]mpls
Info: Mpls starting, please wait... OK!
[r2]mpls ldp
[r2-mpls-ldp]int g 0/0/0
[r2-GigabitEthernet0/0/0]mpls
[r2-GigabitEthernet0/0/0]mpls ldp
[r3]mpls lsr-id 3.3.3.3
[r3]mpls
Info: Mpls starting, please wait... OK!
[r3-mpls]mpls ldp
[r3-mpls-ldp]int g 0/0/1
[r3-GigabitEthernet0/0/1]mpls
[r3-GigabitEthernet0/0/1]mpls ldp
[r3-GigabitEthernet0/0/1]int g 0/0/0
[r3-GigabitEthernet0/0/0]mpls
[r3-GigabitEthernet0/0/0]mpls ldp
[r4]mpls lsr-id 4.4.4.4
[r4]mpls
Info: Mpls starting, please wait... OK!
[r4-mpls]mpls ldp
[r4-mpls-ldp]int g 0/0/1
[r4-GigabitEthernet0/0/1]mpls
[r4-GigabitEthernet0/0/1]mpls ldp

3.创建VPN并配置私网地址与路由配置

[r2]ip vpn-instance a
[r2-vpn-instance-a]ipv4-family 
[r2-vpn-instance-a-af-ipv4]route-distinguisher 1:1
[r2-vpn-instance-a-af-ipv4]vpn-target 1:1
 IVT Assignment result: 
Info: VPN-Target assignment is successful.
 EVT Assignment result: 
Info: VPN-Target assignment is successful.	
[r2-vpn-instance-a-af-ipv4]int g 0/0/1	
[r2-GigabitEthernet0/0/1]ip binding vpn-instance a
Info: All IPv4 related configurations on this interface are removed!
Info: All IPv6 related configurations on this interface are removed!
[r2-GigabitEthernet0/0/1]ip address 192.168.2.2 24
Mar  2 2021 19:18:04-08:00 r2 %%01IFNET/4/LINK_STATE(l)[0]:The line protocol IP 
on the interface GigabitEthernet0/0/1 has entered the UP state. 
[r2]ip vpn-instance b
[r2-vpn-instance-b]ipv4-family 	
[r2-vpn-instance-b-af-ipv4]route-distinguisher 2:2	
[r2-vpn-instance-b-af-ipv4]vpn-target 2:2
 IVT Assignment result: 
Info: VPN-Target assignment is successful.
 EVT Assignment result: 
Info: VPN-Target assignment is successful.
[r2-vpn-instance-b-af-ipv4]int g 0/0/2
[r2-GigabitEthernet0/0/2]ip binding vpn-instance b
Info: All IPv4 related configurations on this interface are removed!
Info: All IPv6 related configurations on this interface are removed!
[r2-GigabitEthernet0/0/2]ip address 192.168.2.2 24
Mar  2 2021 19:20:55-08:00 r2 %%01IFNET/4/LINK_STATE(l)[1]:The line protocol IP 
on the interface GigabitEthernet0/0/2 has entered the UP state. 
[r4]ip vpn-instance a
[r4-vpn-instance-a]ipv4-family 
[r4-vpn-instance-a-af-ipv4]route-distinguisher 1:1	
[r4-vpn-instance-a-af-ipv4]vpn-target 1:1
 IVT Assignment result: 
Info: VPN-Target assignment is successful.
 EVT Assignment result: 
Info: VPN-Target assignment is successful.
[r4-vpn-instance-a-af-ipv4]int g 0/0/0
[r4-GigabitEthernet0/0/0]ip binding vpn-instance a
Info: All IPv4 related configurations on this interface are removed!
Info: All IPv6 related configurations on this interface are removed!
[r4-GigabitEthernet0/0/0]ip address 192.168.3.2 24
Mar  2 2021 19:23:11-08:00 r4 %%01IFNET/4/LINK_STATE(l)[0]:The line protocol IP 
on the interface GigabitEthernet0/0/0 has entered the UP state.
[r4]ip vpn-instance b
[r4-vpn-instance-b]ipv4-family 
[r4-vpn-instance-b-af-ipv4]route-distinguisher 2:2
[r4-vpn-instance-b-af-ipv4]vpn-target 2:2
 IVT Assignment result: 
Info: VPN-Target assignment is successful.
 EVT Assignment result: 
Info: VPN-Target assignment is successful.
[r4-vpn-instance-b-af-ipv4]int g 4/0/0
[r4-GigabitEthernet4/0/0]ip binding vpn-instance b
Info: All IPv4 related configurations on this interface are removed!
Info: All IPv6 related configurations on this interface are removed!
[r4-GigabitEthernet4/0/0]ip address 192.168.3.2 24
Mar  2 2021 19:25:32-08:00 r4 %%01IFNET/4/LINK_STATE(l)[1]:The line protocol IP 
on the interface GigabitEthernet4/0/0 has entered the UP state. 
[r1]int l 0
[r1-LoopBack0]ip ad 192.168.1.1 24
[r1-LoopBack0]int g 0/0/0
[r1-GigabitEthernet0/0/0]ip ad 192.168.2.1 24
[r6]int l 0
[r6-LoopBack0]ip ad 192.168.1.1 24
[r6-LoopBack0]int g 0/0/2
[r6-GigabitEthernet0/0/2]ip ad 192.168.2.1 24
[r5]int l0
[r5-LoopBack0]ip ad 192.168.4.1 24
[r5-LoopBack0]int g 0/0/1
[r5-GigabitEthernet0/0/1]ip ad 192.168.3.1 24
[r7]int l 0
[r7-LoopBack0]ip ad 192.168.4.2 24
[r7-LoopBack0]int g  0/0/0
[r7-GigabitEthernet0/0/0]ip ad 192.168.3.1 24
[r1]ip route-static 192.168.3.0 24 192.168.2.2
[r1]ip route-static 192.168.4.0 24 192.168.2.2
[r5]ip route-static 192.168.1.0 24 192.168.3.2
[r5]ip route-static 192.168.2.0 24 192.168.3.2
[r6]rip 1	
[r6-rip-1]version 2
[r6-rip-1]undo summary	
[r6-rip-1]network 192.168.1.0
[r7]ospf 2 router-id 7.7.7.7	
[r7-ospf-2]area 0	
[r7-ospf-2-area-0.0.0.0]network 192.168.4.2 0.0.0.0
[r7-ospf-2-area-0.0.0.0]network 192.168.3.1 0.0.0.0

4.创建BGP与双向重发布

[r2]bgp 1
[r2-bgp]router-id 2.2.2.2
[r2-bgp]peer 4.4.4.4 as-number 1	
[r2-bgp]peer 4.4.4.4 connect-interface LoopBack 0
[r2-bgp]ipv4-family vpnv4
[r2-bgp-af-vpnv4]peer 4.4.4.4 enable 
[r4]bgp 1
[r4-bgp]router-id 4.4.4.4
[r4-bgp]peer 2.2.2.2 as-number 1	
[r4-bgp]peer 2.2.2.2 connect-interface LoopBack 0
[r4-bgp]ipv4-family vpnv4
[r4-bgp-af-vpnv4]peer 2.2.2.2 enable 
[r2]rip 1 vpn-instance b
[r2-rip-1]network 192.168.2.0
[r4]ospf 1 vpn-instance b
[r4-ospf-1-area-0.0.0.0]network 192.168.3.2 0.0.0.0
[r2]bgp 1		
[r2-bgp]ipv4-family vpn-instance b	
[r2-bgp]import-route rip 1
[r2]rip 1 vpn-instance b
[r2-rip-1]import-route bgp 1
[r4]bgp 1	
[r4-bgp]ipv4-family vpn-instance b	
[r4-bgp]import-route ospf 2
[r4]ospf 2 vpn-instance b
[r4-ospf-2]import-route bgp 1
[r2]ip route-static vpn-instance a 192.168.1.0 24 192.168.2.1
[r2]bgp 1
[r2-bgp]ipv4-family vpn-instance a
[r2-bgp]import-route static 
[r2-bgp]import-route direct
[r4]ip route-static vpn-instance a 192.168.4.0 24 192.168.3.1
[r4]bgp 1
[r4-bgp]ipv4-family vpn-instance a
[r4-bgp]import-route static 
[r4-bgp]import-route direct
  • 7
    点赞
  • 42
    收藏
    觉得还不错? 一键收藏
  • 2
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值