Welcome

问题 A: Welcome
[命题人 : 201501010119]
时间限制 : 1.000 sec 内存限制 : 128 MB

题目描述
”How happy we are, To meet friends from afar!”
Welcome to Hunan University of Chinese Medicine!
Hope all of you can enjoy the competition ^ v ^
Now your task is to read an integer w and output the character painting of ”HNUCM”, there are w
space(s) (space are represented by dot) between two letters. Please refer to the sample for the specific
format.
输入
There are several test files and each contains one case.
The input contains only 1 integer w (1 ≤ w ≤ 2018).
输出
The output has 5 lines, each line has 25+4w characters which only contains ’o’(lowercase letter ’o’) and
’.’(English period ’.’)
样例输入 Copy
1
样例输出 Copy
o…o.o…o.o…o.ooooo.o…o
o…o.oo…o.o…o.o…oo.oo
ooooo.o.o.o.o…o.o…o.o.o
o…o.o…oo.o…o.o…o…o
o…o.o…o.ooooo.ooooo.o…o

#include <stdio.h>
#include <stdlib.h>
#include <string.h>
void dot(int n){
for(int i=0;i<n;i++){
    printf(".");
}
}
int main()
{
    int n;
    while(~scanf("%d",&n)){
       /* char s1[6]="o...o";
        char s2[6]="ooooo";
        char s3[5]="oo..o";
        char s4[5]="oo.oo";
        char s5[5]="o.o.o";
        char s6[5]="o....";
        char s7[5]="o..oo";*/
printf("o...o"); dot(n); printf("o...o"); dot(n); printf("o...o"); dot(n); printf("ooooo"); dot(n); printf("o...o\n");
printf("o...o"); dot(n); printf("oo..o"); dot(n); printf("o...o"); dot(n); printf("o...."); dot(n); printf("oo.oo\n");
printf("ooooo"); dot(n); printf("o.o.o");dot(n); printf("o...o");dot(n); printf("o....");dot(n); printf("o.o.o\n");
printf("o...o");dot(n); printf("o..oo"); dot(n); printf("o...o"); dot(n); printf("o...."); dot(n);printf("o...o\n");
printf("o...o"); dot(n); printf("o...o"); dot(n); printf("ooooo"); dot(n);printf("ooooo"); dot(n); printf("o...o\n");
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值