map和next_permutation()

注:依旧是《算法竞赛入门到进阶》的学习哦~~

map

map是关联容器,它实现从键(key)到值(value)的映射

题目:(来自vj)

very girl likes shopping,so does dandelion.
Now she finds the shop is increasing the price every day because the Spring Festival is coming .
She is fond of a shop which is called “memory”. Now she wants to know the rank of this shop’s price after the change of everyday.
Input
One line contians a number n ( n<=10000),stands for the number of shops.
Then n lines ,each line contains a string (the length is short than 31 and only contains lowercase letters and capital letters.)stands for the name of the shop.
Then a line contians a number m (1<=m<=50),stands for the days .
Then m parts , every parts contians n lines , each line contians a number s and a string p ,stands for this day ,the shop p 's price has increased s.
Output
Contains m lines ,In the ith line print a number of the shop “memory” ‘s rank after the ith day.
We define the rank as :If there are t shops’ price is higher than the “memory” , than its rank is t+1.
Sample Input
3
memory
kfc
wind
2
49 memory
49 kfc
48 wind
80 kfc
85 wind
83 memory
Sample Output
1
2

#include <iostream>
#include <string>
#include <map>
#include <iterator>
 using namespace std;
 int main()
 {
     int n,m,p;
     map<string,int>shop;
     while(cin>>n){
         string s;
         for(int i=1;i<=n;i++){
             cin>>s;
         }
         cin>>m;
         while(m--){
             for(int i=1;i<=n;i++){
                 cin>>p>>s;
                 shop[s]+=p;//用map可以直接操作商店,加上价格
             }
             int rank=1;
             map<string,int>::iterator it;//这里又是迭代器
             for(it=shop.begin();it!=shop.end();it++){
                 if(it->second>shop["memory"]){//比较价格,如果不明白it->second下面有注释哦~
                     rank++;
                 }
             }
             cout<<rank<<endl;
         }
         shop.clear() ;
     }
     return 0;
  } 

https://bbs.csdn.net/topics/390859109 可了解以下it->second

next_permutation()

STL提供求下一个排列组合的函数。
返回值:如果没有下一个排列组合,返回false,否则返回true。每执行next_permutation()一次,就会把新的排列放在原来的空间里。
注意:它排列的范围是[first,last),包括first,不包括last

题目:

Now our hero finds the door to the BEelzebub feng5166. He opens the door and finds feng5166 is about to kill our pretty Princess. But now the BEelzebub has to beat our hero first. feng5166 says, “I have three question for you, if you can work them out, I will release the Princess, or you will be my dinner, too.” Ignatius says confidently, “OK, at last, I will save the Princess.”

“Now I will show you the first problem.” feng5166 says, “Given a sequence of number 1 to N, we define that 1,2,3…N-1,N is the smallest sequence among all the sequence which can be composed with number 1 to N(each number can be and should be use only once in this problem). So it’s easy to see the second smallest sequence is 1,2,3…N,N-1. Now I will give you two numbers, N and M. You should tell me the Mth smallest sequence which is composed with number 1 to N. It’s easy, isn’t is? Hahahahaha…”
Can you help Ignatius to solve this problem?

Input

The input contains several test cases. Each test case consists of two numbers, N and M(1<=N<=1000, 1<=M<=10000). You may assume that there is always a sequence satisfied the BEelzebub’s demand. The input is terminated by the end of file.

Output

For each test case, you only have to output the sequence satisfied the BEelzebub’s demand. When output a sequence, you should print a space between two numbers, but do not output any spaces after the last number.

Sample Input
6 4
11 8

Sample Output
1 2 3 5 6 4
1 2 3 4 5 6 7 9 8 11 10

#include <algorithm>//注意头文件
#include <iostream>
 using namespace std;
 int a[1001];
 int main()
 {
     int n,m;
     while(cin>>n>>m){
         for(int i=1;i<=n;i++){
             a[i]=i;
         }
        int b=1;
        do{
            if(b==m){
                break;
            }
            b++;
        }while(next_permutation(a+1,a+n+1));
        for(int i=1;i<n;i++){
            cout<<a[i]<<' ';
        }
        cout<<a[n]<<endl;
     }
     return 0;
 }

(在这里想啰嗦几句话哈~因为这个代码我自己也写了一遍用while(){}写的然后就得改成b==m-1,所以在这里强调以下while和do while的区别嘿嘿嘿)

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值