The Pilots Brothers‘ Refrigerator(高效贪心)

题目描述
The game “The Pilots Brothers: following the stripy elephant” has a quest where a player needs to open a refrigerator.
There are 16 handles on the refrigerator door. Every handle can be in one of two states: open or closed. The refrigerator is open only when all handles are open. The handles are represented as a matrix 4х4. You can change the state of a handle in any location [i, j] (1≤i,j≤4). However, this also changes states of all handles in row i and all handles in column j.
The task is to determine the minimum number of handle switching necessary to open the refrigerator.

输入
The input contains four lines. Each of the four lines contains four characters describing the initial state of appropriate handles. A symbol “+” means that the handle is in closed state, whereas the symbol “−” means “open”. At least one of the handles is initially closed.

输出
The first line of the input contains N – the minimum number of switching. The rest N lines describe switching sequence. Each of the lines contains a row number and a column number of the matrix separated by one or more spaces. If there are several solutions, you may give any one of them.
样例输入 Copy
截图
样例输出 Copy
6
1 1
1 3
1 4
4 1
4 3
4 4

思路
因为这个思路真的很有意思,所以就好好瞅瞅嘿嘿嘿~

  • 以题目中所给例子来跟大家聊聊哈!我们可以开一个新的二维数组vis[5][5](是5而不是4的原因是我用4写的时候数据溢出),vis数组对应我们输入的char型二维数组可看成
    在这里插入图片描述
  • 如果遍历二维的char,有“+”的位置就让它所在的行和列发生相应的改变,也就是将对应的vis数组的位置加1,记录改变次数
  • 我们可以得到如下记录
    在这里插入图片描述
  • 我们就能发现了一个“神奇”的事情:二维数组里的奇数所在的位置,就是我们需要改变的位置。
  • 这是为什么呢?
  • 只在有“+”的位置让它对应的行和列发生相应改变是因为要先确定哪些位置会被“波及”到,同理,也只有这些非零的位置中有可能存在我们要改变的位置。
  • 明确:经过偶数次的变化不会使这个位置的+或者-号发生变化,只有奇数次能实现改变。也就是说,图中的是偶数的位置的变化并不会帮助我们达到全“-”,是无效的位置,而是奇数的位置可以,是有效的位置。
#include <bits/stdc++.h>
 using namespace std;
 char c[5][5];
 int step=0;
 int vis[5][5];
 int main()
 {
 	memset(vis,0,sizeof(vis));
 	for(int i=1;i<=4;i++)
 	{
 		for(int j=1;j<=4;j++)
 		{
 			cin>>c[i][j];
		 }
	 }
	 for(int i=1;i<=4;i++)
	 {
	 	for(int j=1;j<=4;j++)
	 	{
	 		if(c[i][j]=='+')
	 		{
	 		  for(int k=1;k<=4;k++)
	 		 {
	 			vis[i][k]++;
				vis[k][j]++;  
			 }
			vis[i][j]--;
		    }
		 }
	 }
	for(int i=1;i<=4;i++)
	{
		for(int j=1;j<=4;j++)
		{
			if(vis[i][j]%2)
			{
				step++;
			}
		}
	}
	cout<<step<<endl;
	for(int i=1;i<=4;i++)
	{
		for(int j=1;j<=4;j++)
		{
			if(vis[i][j]%2)
			{
				cout<<i<<" "<<j<<endl;
			}
		}
	}
	return 0;
 }
  • 4
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值