Equations
Consider equations having the following form:
ax1^2+ bx2 ^2 +cx3 ^2 +dx4 ^2=0
a, b, c, d are integers from the interval [-50,50] and any of them cannot be 0.
It is consider a solution a system ( x1,x2,x3,x4 ) that verifies the equation, xi is an integer from [-100,100] and xi != 0, any i ∈{1,2,3,4}.
Determine how many solutions satisfy the given equation.
Input
The input consists of several test cases. Each test case consists of a single line containing the 4 coefficients a, b, c, d, separated by one or more blanks.
End of file.
Output
For each test case, output a single line containing the number of the solutions.
Sample Input
1 2 3 -4
1 1 1 1
Sample Output
39088
0
思路:根据方程式可知是从[-100,100]区间内找出合适的解的个数,但未知数是平方的形式且x不等于0,则只需从[1,100]区间内求解即可,因为对于每一组成立的方程来说,方程解唯一,因此可以把方程拆成任意两部分看待,ax1x1+bx2x2与cx3x3+dx4x4(也可拆成ax1x1+cx3x3与dx4x4+bx2x2,任意两组都可),对第一部分进行运算并标记,之后只需在第二部分中找出标记值的相反数即可,以这样的方式找到的组数再乘以16便是最后得出的结果。
#include<iostream>
using namespace std;
long long a1[1100000];
long long b1[1100000];
int main()
{
int a,b,c,d;
int i,j;
long long k;
while(scanf("%d%d%d%d",&a,&b,&c,&d)!=EOF){
if((a>0&&b>0&&c>0&&d>0)||(a<0&&b<0&&c<0&&d<0)){
printf("0\n");
}else{
memset(a1,0,sizeof(a1));
memset(b1,0,sizeof(b1));
for(i=1;i<=100;i++){
for(j=1;j<=100;j++){
k=a*i*i+b*j*j;
if(k>=0){
a1[k]++;
}else{
k=-k;
b1[k]++;
}
}
}
int ans=0;
for(i=1;i<=100;i++){
for(j=1;j<=100;j++){
k=c*i*i+d*j*j;
if(k>0){
ans=ans+b1[k];
}else{
k=-k;
ans=ans+a1[k];
}
}
}
printf("%d\n",ans*16);
}
}
}