Koch Curve

本文介绍如何使用Python编写一个程序,通过递归调用生成n级Koch曲线。从0到100的区间作为起始线段,根据给定的整数n决定复杂度,输出科赫曲线上的每个点,精确到小数点后8位。程序涉及几何变换和递归算法,适合学习算法和图形绘制。
摘要由CSDN通过智能技术生成

Koch Curve(科赫曲线)

Write a program which reads an integer n and draws a Koch curve based on recursive calles of depth n.

The Koch curve is well known as a kind of fractals.

You can draw a Koch curve in the following algorithm:

Divide a given segment (p1, p2) into three equal segments.
Replace the middle segment by the two sides of an equilateral triangle (s, u, t) of the same length as the segment.
Repeat this procedure recursively for new segments (p1, s), (s, u), (u, t), (t, p2).
在这里插入图片描述

You should start (0, 0), (100, 0) as the first segment.

Input
An integer n is given.

Output
Print each point (x, y) of the Koch curve. Print a point in a line. You should start the point(0, 0), which is the endpoint of the first segment and end with the point (100, 0), the other endpoint so that you can draw the Koch curve as an unbroken line. Each solution should be given as a decimal with an arbitrary number of fractional digits, and with an absolute error of at most 10-4.

Constraints
0 ≤ n ≤ 6
Sample Input 1
1
Sample Output 1
0.00000000 0.00000000
33.33333333 0.00000000
50.00000000 28.86751346
66.66666667 0.00000000
100.00000000 0.00000000
Sample Input 2
2
Sample Output 2
0.00000000 0.00000000
11.11111111 0.00000000
16.66666667 9.62250449
22.22222222 0.00000000
33.33333333 0.00000000
38.88888889 9.62250449
33.33333333 19.24500897
44.44444444 19.24500897
50.00000000 28.86751346
55.55555556 19.24500897
66.66666667 19.24500897
61.11111111 9.62250449
66.66666667 0.00000000
77.77777778 0.00000000
83.33333333 9.62250449
88.88888889 0.00000000
100.00000000 0.00000000
Notes

	double th=M_PI*60.0/180;  //把单位从度变为弧度,M_PI就是Π
	s.x=(2.0*a.x+1.0*b.x)/3.0; //求s点的坐标 
	s.y=(2.0*a.y+1.0*b.y)/3.0;
	t.x=(1.0*a.x+2.0*b.x)/3.0; //求y点坐标 
	t.y=(1.0*a.y+2.0*b.y)/3.0;
	u.x=(t.x-s.x)*cos(th)-(t.y-s.y)*sin(th)+s.x; //采用旋转矩阵,求出点u的坐标
	u.y=(t.x-s.x)*sin(th)+(t.y-s.y)*cos(th)+s.y;
	koch(n-1,a,s);  递归,以两个点为端点的线段来递归求新的科赫曲线
	printf("%.8lf %.8lf\n",s.x,s.y);
	koch(n-1,s,u);
	printf("%.8lf %.8lf\n",u.x,u.y);
	koch(n-1,u,t);
	printf("%.8lf %.8lf\n",t.x,t.y);
	koch(n-1,t,b);
#include<iostream>
#include<cstring>
#include<math.h>
#include<algorithm>
using namespace std;
struct Point{
	double x,y;
};
void koch(int n,Point a,Point b){
	if(n==0) return ;
	Point s,t,u;
	double th=M_PI*60.0/180;  
	s.x=(2.0*a.x+1.0*b.x)/3.0; 
	s.y=(2.0*a.y+1.0*b.y)/3.0;
	t.x=(1.0*a.x+2.0*b.x)/3.0;  
	t.y=(1.0*a.y+2.0*b.y)/3.0;
	u.x=(t.x-s.x)*cos(th)-(t.y-s.y)*sin(th)+s.x; 
	u.y=(t.x-s.x)*sin(th)+(t.y-s.y)*cos(th)+s.y;
	koch(n-1,a,s);
	printf("%.8lf %.8lf\n",s.x,s.y);
	koch(n-1,s,u);
	printf("%.8lf %.8lf\n",u.x,u.y);
	koch(n-1,u,t);
	printf("%.8lf %.8lf\n",t.x,t.y);
	koch(n-1,t,b);
}
int main(){
	Point a,b;
	int n;
	scanf("%d",&n);
	a.x=0;
	a.y=0;
	b.x=100;
	b.y=0;
	printf("%.8lf %.8lf\n",a.x,a.y);
	koch(n,a,b);
	printf("%.8lf %.8lf\n",b.x,b.y);
	return 0;
}

如果你有任何建议或者批评和补充,请留言指出,不胜感激

评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值