【PAT(甲级)】1015 Reversible Primes

reversible prime in any number system is a prime whose "reverse" in that number system is also a prime. For example in the decimal system 73 is a reversible prime because its reverse 37 is also a prime.

Now given any two positive integers N (<10^{5}) and D (1<D≤10), you are supposed to tell if N is a reversible prime with radix D.

Input Specification:

The input file consists of several test cases. Each case occupies a line which contains two integers N and D. The input is finished by a negative N.

Output Specification:

For each test case, print in one line Yes if N is a reversible prime with radix D, or No if not.

Sample Input:

73 10
23 2
23 10
-2

Sample Output:

Yes
Yes
No

解题思路:

这题只要写函数实现下面几个功能就行:

1. 数字的反转例如把110110反转成11011

2.素数的判断

3.进制的转换

然后按照题意,对本身以及反转后数字依旧是素数的输出“Yes”,反之输出“No”。

易错点:代码:

1. 题目中给出的都是10进制数,要按照要求反转成D进制。素数的判断就是给的数本身是素数,改成D进制后反转,再换成10进制还是素数。

2. 测试点3中的数很大,如果D是二进制的话,N(<10^{5})换算成二进制是long long int。

代码:

#include<bits/stdc++.h>
using namespace std;

long long int rt(int a,int b){//按照b进制将a转换成十进制 
	int sum=0;int j=0;
	if(b==10) return a;
	while(a!=0){
	 	sum+=a%10*pow(b,j++);
	 	a/=10;
	}
	return sum;
}

long long int r_D(int a,int b){//对十进制a转换成b进制的数  
	stack<int> tol;
	if(a==0) return 0;
	while(a!=0){
		tol.push(a%b);
		a/=b;
	}
	long long int sum=0;
	while(!tol.empty()){
		sum=sum*10+tol.top();
		tol.pop();
	}
	return sum;
}

long long int Reserve(long long int a){//反转数 
	long long int sum=0;
	while(a!=0){
		sum=sum*10+a%10;
		a/=10;
	}
	return sum;
}

bool is_prime(int a){//判断是否为素数 
	if(a==0||a==1) return false;
	for(int i=2;i<=sqrt(a);i++){
		if(a%i==0) return false;
	}
	return true;
}

int main(){
	int N,D;
	cin>>N;
	while(N>0){
		cin>>D;
		if(is_prime(N)&&is_prime(rt(Reserve(r_D(N,D)),D)))
			cout<<"Yes"<<endl;
		else
			cout<<"No"<<endl;
		cin>>N;
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值