1039 Course List for Student (25分)

Zhejiang University has 40000 students and provides 2500 courses. Now given the student name lists of all the courses, you are supposed to output the registered course list for each student who comes for a query.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers: N (≤40,000), the number of students who look for their course lists, and K (≤2,500), the total number of courses. Then the student name lists are given for the courses (numbered from 1 to K) in the following format: for each course i, first the course index i and the number of registered students N
​i(≤200) are given in a line. Then in the next line, N​istudent names are given. A student name consists of 3 capital English letters plus a one-digit number. Finally the last line contains the N names of students who come for a query. All the names and numbers in a line are separated by a space.

Output Specification:

For each test case, print your results in N lines. Each line corresponds to one student, in the following format: first print the student’s name, then the total number of registered courses of that student, and finally the indices of the courses in increasing order. The query results must be printed in the same order as input. All the data in a line must be separated by a space, with no extra space at the end of the line.

Sample Input:

11 5
4 7
BOB5 DON2 FRA8 JAY9 KAT3 LOR6 ZOE1
1 4
ANN0 BOB5 JAY9 LOR6
2 7
ANN0 BOB5 FRA8 JAY9 JOE4 KAT3 LOR6
3 1
BOB5
5 9
AMY7 ANN0 BOB5 DON2 FRA8 JAY9 KAT3 LOR6 ZOE1
ZOE1 ANN0 BOB5 JOE4 JAY9 FRA8 DON2 AMY7 KAT3 LOR6 NON9

Sample Output:

ZOE1 2 4 5
ANN0 3 1 2 5
BOB5 5 1 2 3 4 5
JOE4 1 2
JAY9 4 1 2 4 5
FRA8 3 2 4 5
DON2 2 4 5
AMY7 1 5
KAT3 3 2 4 5
LOR6 4 1 2 4 5
NON9 0

解析:

一开始想的是用map<string,set< int> >的办法,建立每个学生和他所有课程号的映射,可是发现总有两个判定点过不去,21分
错误代码:

#include<bits/stdc++.h>

using namespace std;
int n, k, m;
map<string, set<int> > mp;

int main() {
    cin >> n >> k;
    for (int i = 1; i <= k; i++) {
        int id, num;
        scanf("%d%d", &id, &num);
        getchar();
        string name;
        while (cin >> name) {
            mp[name].insert(id);
            if (getchar() == '\n')break;
        }
    }
    string t;
    while (cin >> t) {
        printf("%s %d", t.c_str(), mp[t].size());
        for (auto x = mp[t].begin(); x != mp[t].end(); x++)
            printf(" %d", *x);
        printf("\n");
        if (getchar() == '\n')break;
    }
}

在这里插入图片描述
后来看了别的博客发现都是用hash替代map的映射的,因为大数据的时候string的map映射会超时
emmm,那我这个是什么情况??
后来想了一下我的这种map映射逻辑上应该是没有问题,可能是边界和大数据的测试样例故意卡?后来用hash的方法做了一下,思路如下:

因为学生的姓名是固定格式的,所以用string存储姓名会浪费题目给你铺垫的条件 ,我想这也就是为什么hash成为这道题目的解题策略,不是hash的话肯定会用特殊的样例卡你。
学生姓名是三个大写英文字母+一个数字,所以可以用下面这种公式计算一个name的hash值:

for i 3 to 1:
	hash+= ((name[3-i] - 'A') * 26 ^ (i-1))*10
if	i == 4:
	hash+= name[i] - '0'
return hash

这个公式看着有点复杂,其实含义就是前三位字母权重的基数是26,最后一位数字基数是10,然后按照位数分配权重;
比方说 ABC1,就是(A-‘A’)* 26 * 26 * 10 + (B-‘A’) * 26 * 10 + (C-‘A’) * 10 + 1 = 281
代码实现如下:

int Hash(const char *name) {
    int sum = 0;
    for (int i = 0; i < 3; i++)
        sum = sum * 26 + name[i] - 'A';
    return sum * 10 + name[3] - '0';
}

这种线性处理的方法适用于很多有关于权重分配的题目,比方说进制转换
最终代码:

#include<bits/stdc++.h>

#define Max 26*26*26*10+1//hash映射的最大值,比方说ZZZ9
using namespace std;
int n, k, m;
set<int> mp[Max];//hash映射仿map
int Hash(const char *name) {
    int sum = 0;
    for (int i = 0; i < 3; i++)
        sum = sum * 26 + name[i] - 'A';
    return sum * 10 + name[3] - '0';
}

int main() {
    cin >> n >> k;
    for (int i = 1; i <= k; i++) {
        int id, num;
        scanf("%d%d", &id, &num);
        getchar();
        char name[4];
        for (int j = 0; j < num; j++) {
            scanf("%s", name);
            int tt = Hash(name);
            mp[tt].insert(id);
        }
    }
    string t;
    while (cin >> t) {
        int tt = Hash(t.c_str());
        printf("%s %d", t.c_str(), mp[tt].size());
        for (auto x = mp[tt].begin(); x != mp[tt].end(); x++)
            printf(" %d", *x);
        printf("\n");
        if (getchar() == '\n')break;
    }
}

在这里插入图片描述

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值