1081 检查密码

1081 检查密码

分数 15
作者 CHEN, Yue
单位 浙江大学

本题要求你帮助某网站的用户注册模块写一个密码合法性检查的小功能。该网站要求用户设置的密码必须由不少于6个字符组成,并且只能有英文字母、数字和小数点 .,还必须既有字母也有数字。

输入格式:

输入第一行给出一个正整数 N(≤ 100),随后 N 行,每行给出一个用户设置的密码,为不超过 80 个字符的非空字符串,以回车结束。

注意: 题目保证不存在只有小数点的输入。

输出格式:

对每个用户的密码,在一行中输出系统反馈信息,分以下5种:

如果密码合法,输出Your password is wan mei.;
如果密码太短,不论合法与否,都输出Your password is tai duan le.;
如果密码长度合法,但存在不合法字符,则输出Your password is tai luan le.;
如果密码长度合法,但只有字母没有数字,则输出Your password needs shu zi.;
如果密码长度合法,但只有数字没有字母,则输出Your password needs zi mu.。

输入样例:

5
123s
zheshi.wodepw
1234.5678
WanMei23333
pass*word.6

输出样例:

Your password is tai duan le.
Your password needs shu zi.
Your password needs zi mu.
Your password is wan mei.
Your password is tai luan le.

思路分析:

  • 设置 int alpha_num = 0;和 int digit_num = 0; 不断计数 。如果有一个为0则输出。
  • illegal 用来判断某个字符是否合法 ,不合法直接输出并赋值为1,跳出循环。然后判断是否为1,为1则continue 就不用接下来的判断了。
  • 而且题目保证没有全小数点的密码,所以字母或数字至少有1个。

错误分析:

  • 又是常犯地错误,数字个数和字母个数一开始定义在for外面,结果是不断的自增,导致后面判断错误。定义在for代码块内就好了。
  • isdigit如果是数字 返回非0值,而不是1

代码实现:

#include<stdio.h>
#include<string.h>
#include<ctype.h>
int main(){
    int n;
    scanf("%d",&n);
    getchar();
    char password[81];
    int len = 0;
    int illegal = 0;//非法字符
    for(int i = 0; i < n; i++){
    	int alpha_num = 0;
    	int digit_num = 0;
		gets(password); 
        len = strlen(password);
        if(len < 6){
            printf("Your password is tai duan le.\n");
            continue;
        }
        for(int j = 0; j < len; j ++){
        	if(isdigit(password[j])){
        		digit_num ++;
			} 
			else if(isalpha(password[j])){
				alpha_num ++;		
			}
			else if(password[j] != '.'){
				illegal = 1;
				printf("Your password is tai luan le.\n");
                break;
			}
        }
        if(illegal == 1){
            illegal = 0;
            continue;
        }
        if(digit_num == 0){
            printf("Your password needs shu zi.\n");
            continue;
        }
        if(alpha_num == 0){
            printf("Your password needs zi mu.\n");
            
            continue;
        }
        printf("Your password is wan mei.\n");
    }
}

参考:

C 库函数 - isdigit()

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值