1008 Elevator PAT 甲级真题

The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop.

For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.

Input Specification:

Each input file contains one test case. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100.

Output Specification:

For each test case, print the total time on a single line.

Sample Input:

3 2 3 1

Sample Output:

41

参考翻译:

我们城市最高的建筑只有一部电梯。请求列表由N个正数组成。数字表示电梯将按特定顺序停在哪个楼层。电梯上一层需要6秒,下一层需要4秒。电梯每站停留5秒。

对于给定的请求列表,您将计算完成列表上的请求所花费的总时间。电梯一开始在0楼,当要求得到满足时,不需要返回一楼。

输入规格:

每个输入文件包含一个测试用例。每种情况都包含一个正整数N,后面跟着N个正数。输入的所有数字都小于100。

输出规范:

对于每个测试用例,将总时间打印在一行上。

代码:

#include<iostream>
#include<vector>
using namespace std;

int num[1000000];
int main(){
    int n;
    int now_floor = 0;
    int sum = 0;
    cin>> n;
    for(int i = 1; i <= n ; i++)
    {
        cin >> num[i];
        if(num[i] >= now_floor ){
            sum =sum+ (num[i]-now_floor)*6;
           
        }else{
            sum =sum+ ( now_floor - num[i])*4;
        }
         sum = sum + 5;
        now_floor = num[i];
       // cout<<sum<<"\n";
    }
    cout<<sum<<"\n";
    return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值