1032 Sharing PAT 甲级真题

文章描述了一种使用链表按字母存储英语单词的方法,以节省空间,特别是当单词有相同后缀时。给定两个单词的链表表示,任务是找到它们共享的后缀起始位置。如果无共享后缀,则输出-1。输入包含链表节点信息,输出是共享后缀的起始位置节点地址。
摘要由CSDN通过智能技术生成

To store English words, one method is to use linked lists and store a word letter by letter. To save some space, we may let the words share the same sublist if they share the same suffix. For example, and are stored as showed in Figure 1.loadingbeing

Figure 1

You are supposed to find the starting position of the common suffix (e.g. the position of in Figure 1).i

Input Specification:

Each input file contains one test case. For each case, the first line contains two addresses of nodes and a positive N (≤105), where the two addresses are the addresses of the first nodes of the two words, and N is the total number of nodes. The address of a node is a 5-digit positive integer, and NULL is represented by −1.

Then N lines follow, each describes a node in the format:

Address Data Next

where is the position of the node, is the letter contained by this node which is an English letter chosen from { a-z, A-Z }, and is the position of the next node.AddressDataNext

Output Specification:

For each case, simply output the 5-digit starting position of the common suffix. If the two words have no common suffix, output instead.-1

Sample Input 1:

11111 22222 9
67890 i 00002
00010 a 12345
00003 g -1
12345 D 67890
00002 n 00003
22222 B 23456
11111 L 00001
23456 e 67890
00001 o 00010

Sample Output 1:

67890

Sample Input 2:

00001 00002 4
00001 a 10001
10001 s -1
00002 a 10002
10002 t -1

Sample Output 2:

-1

参考翻译:

要存储英语单词,一种方法是使用链表并逐个字母存储单词。为了节省一些空间,如果单词共享相同的后缀,我们可能会让它们共享相同的子列表。例如,并如图1所示进行存储。loadingbeing

图1

您应该找到公共后缀的起始位置(例如,图 1 中的位置)。i

输入规范:

每个输入文件包含一个测试用例。对于每种情况,第一行包含两个节点地址和一个正数N (≤105),其中两个地址是两个单词的第一个节点的地址,并且N是节点的总数。节点地址为5位正整数,NULL 表示为−1.

然后N接下来是几行,每行描述一个节点,格式如下:

Address Data Next

其中 是节点的位置,是此节点包含的字母,它是从 { a-z, A-Z } 中选择的英文字母,并且是下一个节点的位置。AddressDataNext

输出规格:

对于每种情况,只需输出公共后缀的 5 位起始位置。如果这两个单词没有共同的后缀,则改为输出。-1

参考代码:

使用静态链表,flag标记第一条链表是否出现过。

#include<iostream>
#include<cstring>
#include<string.h>
using namespace std;
const int N = 100000+100;


struct node{
    string value ;
    int dict = 0;
    bool flag = 0;
}link[N];



int main()
{
    int head_a; int head_b; int n;
    cin  >> head_a >> head_b>> n;
   
    for(int i = 0; i < n; i++)
    {
        int prenode; int lasthead; string value_s;
        cin>>prenode>>value_s>>lasthead;
        link[prenode].value=value_s;
        link[prenode].dict=lasthead;
    }
    
    int a_head = head_a;
    while(a_head != -1)
    {
        link[a_head].flag = true;
        a_head = link[a_head].dict;
    }
    
    int b_head = head_b;
    while(b_head!= -1)
    {
        if(link[b_head].flag==true){
            break;
        }
        b_head = link[b_head].dict;
    }
          
    if(b_head != -1) printf("%05d",b_head);
    else cout<<"-1\n";
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值