PAT A1052 Linked List Sorting C++ 主要的坑

A linked list consists of a series of structures, which are not necessarily adjacent in memory. We assume that each structure contains an integer key and a Next pointer to the next structure. Now given a linked list, you are supposed to sort the structures according to their key values in increasing order.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive N (<105) and an address of the head node, where N is the total number of nodes in memory and the address of a node is a 5-digit positive integer. NULL is represented by −1.

Then N lines follow, each describes a node in the format:

Address Key Next

where Address is the address of the node in memory, Key is an integer in [−105,105], and Next is the address of the next node. It is guaranteed that all the keys are distinct and there is no cycle in the linked list starting from the head node.

Output Specification:

For each test case, the output format is the same as that of the input, where N is the total number of nodes in the list and all the nodes must be sorted order.

Sample Input:

5 00001
11111 100 -1
00001 0 22222
33333 100000 11111
12345 -1 33333
22222 1000 12345

Sample Output:

5 12345
12345 -1 00001
00001 0 11111
11111 100 22222
22222 1000 33333
33333 100000 -1

这个题目坑好多

  1. 如果链表为0,就输出0,-1再直接return

  1. 题目中给的节点不一定都在链表里面 会出现单独的节点 单独的节点不参与排序不输出

  1. vector为空如果访问下标0会出现段错误 这就是测试点5段错误常见问题 只需要增加一个判断

AC代码如下 写的真好 主要是用数组模拟单链表 把链表中每个节点的值与下标作为pair存进vector 再排序

#include<iostream>
#include<algorithm>
#include<vector>
using namespace std;
const int N=100010;
vector<pair<int,int>> v;
int n,head,e[N],ne[N];//e【】用来存下标对应的key,ne【】用来存下一个元素下标
int main()
{
    cin>>n>>head;
    for(int i=0;i<n;++i)
    {
        int address,key,nad;
        cin>>address>>key>>nad;
        e[address]=key,ne[address]=nad;
    }
    for(int i=head;i!=-1;i=ne[i]) v.push_back({e[i],i});
    if(v.empty())
    {
        puts("0 -1");
        return 0;
    }
    sort(v.begin(),v.end());
    printf("%d %05d\n",v.size(),v[0].second);
    for(int i=0;i<v.size();++i)
    {
        printf("%05d %d",v[i].second,v[i].first);
        if(i==v.size()-1) puts(" -1");
        else printf(" %05d\n",v[i+1].second);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值