【PAT A1052】 Linked List Sorting

A linked list consists of a series of structures, which are not necessarily adjacent in memory. We assume that each structure contains an integer key and a Next pointer to the next structure. Now given a linked list, you are supposed to sort the structures according to their key values in increasing order.

Input Specification:
Each input file contains one test case. For each case, the first line contains a positive N (<10^5) and an address of the head node, where N is the total number of nodes in memory and the address of a node is a 5-digit positive integer. NULL is represented by −1.

Then N lines follow, each describes a node in the format:

Address Key Next

where Address is the address of the node in memory, Key is an integer in [−10^ 5, 10^ 5​​], and Next is the address of the next node. It is guaranteed that all the keys are distinct and there is no cycle in the linked list starting from the head node.

Output Specification:
For each test case, the output format is the same as that of the input, where N is the total number of nodes in the list and all the nodes must be sorted order.

Sample Input:

5 00001
11111 100 -1
00001 0 22222
33333 100000 11111
12345 -1 33333
22222 1000 12345

Sample Output:

5 12345
12345 -1 00001
00001 0 11111
11111 100 22222
22222 1000 33333
33333 100000 -1

思路:用flag标记,为-1表示无效结点,为1表示有效结点。定义cmp函数,让无效结点都在右边,有效结点的数据域按从小到大排序。注意最后输出时的next域应该是node[i+1].address(表示下一个结点的地址),而不是node[i].next。
代码参考:《算法笔记》。

#include <cstdio>
#include <algorithm>

using namespace std;
const int maxn = 100010;

struct NODE {//定义静态链表
    int address, data, next;
    bool flag;//结点是否在链表上
} node[maxn];

bool cmp(NODE a, NODE b) {
    if (!a.flag || !b.flag) {//只要a和b中有一个无效结点,就把它放后面去
        return a.flag > b.flag;//有效结点的flag为1,大于无效结点
    } else return a.data < b.data;//如果都是有效结点,则按要求排序
}

int main() {
    for (int i = 0; i < maxn; i++) {
        node[i].flag = false;
    }
    int n, begin;
    scanf("%d%d", &n, &begin);
    int address, next;
    int data;
    for (int i = 0; i < n; i++) {
        scanf("%d %d %d", &address, &data, &next);
        node[address].address = address;
        node[address].data = data;
        node[address].next = next;
    }
    int count = 0, p = begin;
    while (p != -1) {
        node[p].flag = true;//对有效结点进行标记
        count++;//同时记录有效结点个数
        p = node[p].next;
    }
    if (!count) {//没有结点时
        printf("0 -1");
    } else {
        //筛选有效结点,并按data从小到大排序
        sort(node, node + maxn, cmp);
        printf("%d %05d\n", count, node[0].address);
        for (int i = 0; i < count; i++) {
            if (i != count - 1) {//特殊处理最后一个结点
            	//输出时的next域应该是node[i+1].address(表示下一个结点的地址),而不是node[i].next
                printf("%05d %d %05d\n", node[i].address, node[i].data, node[i + 1].address);
            } else printf("%05d %d -1\n", node[i].address, node[i].data);
        }
    }

    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值