6-7 在一个数组中实现两个堆栈 (20分)

本题要求在一个数组中实现两个堆栈。

函数接口定义:

Stack CreateStack( int MaxSize );
bool Push( Stack S, ElementType X, int Tag );
ElementType Pop( Stack S, int Tag );

其中Tag是堆栈编号,取1或2;MaxSize堆栈数组的规模;Stack结构定义如下:

typedef int Position;
struct SNode {
    ElementType *Data;
    Position Top1, Top2;
    int MaxSize;
};
typedef struct SNode *Stack;

注意:如果堆栈已满,Push函数必须输出“Stack Full”并且返回false;如果某堆栈是空的,则Pop函数必须输出“Stack Tag Empty”(其中Tag是该堆栈的编号),并且返回ERROR

裁判测试程序样例:

#include <stdio.h>
#include <stdlib.h>

#define ERROR 1e8
typedef int ElementType;
typedef enum { push, pop, end } Operation;
typedef enum { false, true } bool;
typedef int Position;
struct SNode {
    ElementType *Data;
    Position Top1, Top2;
    int MaxSize;
};
typedef struct SNode *Stack;

Stack CreateStack( int MaxSize );
bool Push( Stack S, ElementType X, int Tag );
ElementType Pop( Stack S, int Tag );

Operation GetOp();  /* details omitted */
void PrintStack( Stack S, int Tag ); /* details omitted */

int main()
{
    int N, Tag, X;
    Stack S;
    int done = 0;

    scanf("%d", &N);
    S = CreateStack(N);
    while ( !done ) {
        switch( GetOp() ) {
        case push: 
            scanf("%d %d", &Tag, &X);
            if (!Push(S, X, Tag)) printf("Stack %d is Full!\n", Tag);
            break;
        case pop:
            scanf("%d", &Tag);
            X = Pop(S, Tag);
            if ( X==ERROR ) printf("Stack %d is Empty!\n", Tag);
            break;
        case end:
            PrintStack(S, 1);
            PrintStack(S, 2);
            done = 1;
            break;
        }
    }
    return 0;
}

/* 你的代码将被嵌在这里 */

输入样例:

5
Push 1 1
Pop 2
Push 2 11
Push 1 2
Push 2 12
Pop 1
Push 2 13
Push 2 14
Push 1 3
Pop 2
End

输出样例:

Stack 2 Empty
Stack 2 is Empty!
Stack Full
Stack 1 is Full!
Pop from Stack 1: 1
Pop from Stack 2: 13 12 11

题解

/*如果堆栈已满,Push函数必须输出“Stack Full”并且返回false;
如果某堆栈是空的,则Pop函数必须输出“Stack Tag Empty”(其中Tag是该堆栈的编号),并且返回ERROR。*/
Stack CreateStack( int MaxSize ){
    Stack stack = (Stack) malloc(sizeof (struct SNode));
    stack->Data = (ElementType*) malloc(sizeof (ElementType)*MaxSize);
    stack->MaxSize  = MaxSize;
    stack->Top1 = -1;
    stack->Top2 = MaxSize;
    return stack;
}
bool Push( Stack S, ElementType X, int Tag ){
    if(S ->Top1 + 1 == S->Top2 ){
        printf("Stack Full\n");
        return false;
    }
    if(Tag == 1){
        S->Data[++S->Top1] = X;
    }
    if(Tag == 2){
        S ->Data[--S->Top2] = X;
    }
    return true;
}
ElementType Pop( Stack S, int Tag ){
    if(Tag == 1){
        if(S->Top1 == -1) {
            printf("Stack %d Empty\n",Tag);
            return ERROR;
        }
        else{
            return S->Data[S->Top1--];
        }
    }
    if(Tag == 2){
        if(S->Top2 == S->MaxSize){
            printf("Stack %d Empty\n",Tag);
            return ERROR;
        }
        else{
          return S->Data[S->Top2++];
        }
    }
}

完整的代码

#include <stdio.h>
#include <stdlib.h>
#include "string.h"

#define ERROR 1e8
typedef int ElementType;
typedef enum { push, pop, end } Operation;
typedef enum { false, true } bool;
typedef int Position;
struct SNode {
    ElementType *Data;
    Position Top1, Top2;
    int MaxSize;
};
typedef struct SNode *Stack;

Stack CreateStack( int MaxSize );
bool Push( Stack S, ElementType X, int Tag );
ElementType Pop( Stack S, int Tag );

Operation GetOp();  /* details omitted */
void PrintStack( Stack S, int Tag ); /* details omitted */

int main()
{
    freopen("/root/tmp/c_data_structure/std.in","r",stdin);
    int N, Tag, X;
    Stack S;
    int done = 0;

    scanf("%d", &N);
    S = CreateStack(N);
    while ( !done ) {
        switch( GetOp() ) {
            case push:
                scanf("%d %d", &Tag, &X);
                if (!Push(S, X, Tag)) printf("Stack %d is Full!\n", Tag);
                break;
            case pop:
                scanf("%d", &Tag);
                X = Pop(S, Tag);
                if ( X==ERROR ) printf("Stack %d is Empty!\n", Tag);
                break;
            case end:
                PrintStack(S, 1);
                PrintStack(S, 2);
                done = 1;
                break;
        }
    }
    return 0;
}
/*如果堆栈已满,Push函数必须输出“Stack Full”并且返回false;
如果某堆栈是空的,则Pop函数必须输出“Stack Tag Empty”(其中Tag是该堆栈的编号),并且返回ERROR。*/
Stack CreateStack( int MaxSize ){
    Stack stack = (Stack) malloc(sizeof (struct SNode));
    stack->Data = (ElementType*) malloc(sizeof (ElementType)*MaxSize);
    stack->MaxSize  = MaxSize;
    stack->Top1 = -1;
    stack->Top2 = MaxSize;
    return stack;
}
bool Push( Stack S, ElementType X, int Tag ){
    if(S ->Top1 + 1 == S->Top2 ){
        printf("Stack Full\n");
        return false;
    }
    if(Tag == 1){
        S->Data[++S->Top1] = X;
    }
    if(Tag == 2){
        S ->Data[--S->Top2] = X;
    }
    return true;
}
ElementType Pop( Stack S, int Tag ){
    if(Tag == 1){
        if(S->Top1 == -1) {
            printf("Stack Tag Empty\n");
            return ERROR;
        }
        else{
            return S->Data[S->Top1--];
        }
    }
    if(Tag == 2){
        if(S->Top2 == S->MaxSize){
            printf("Stack Tag Empty\n");
            return ERROR;
        }
        else{
          return S->Data[S->Top2++];
        }
    }
}

Operation GetOp()  /* details omitted */
{
    Operation operation;
    char op[10];
    scanf("%s",op);
    if(strcmp(op,"Push") == 0){
        return push;
    }
    if(strcmp(op,"Pop") == 0){
        return pop;
    }
    if(strcmp(op,"End") == 0){
        return end;
    }
    return ERROR;

}
void PrintStack( Stack S, int Tag ) /* details omitted */
{
    printf("Pop from Stack %d:", Tag);
    if(Tag == 1) {

        while (S->Top1!=-1){
            printf("% d",S->Data[S->Top1--]);
        }
    }
    if(Tag == 2) {
        while (S->Top2 != S->MaxSize ) {
            printf(" %d", S->Data[S->Top2++]);
        }
    }
    printf("\n");
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

jie3606

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值