03-树2 List Leaves (25 分) --------C语言

Given a tree, you are supposed to list all the leaves in the order of top down, and left to right.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤10) which is the total number of nodes in the tree -- and hence the nodes are numbered from 0 to N−1. Then N lines follow, each corresponds to a node, and gives the indices of the left and right children of the node. If the child does not exist, a "-" will be put at the position. Any pair of children are separated by a space.

Output Specification:

For each test case, print in one line all the leaves' indices in the order of top down, and left to right. There must be exactly one space between any adjacent numbers, and no extra space at the end of the line.

Sample Input:

8
1 -
- -
0 -
2 7
- -
- -
5 -
4 6

结尾无空行

Sample Output:

4 1 5

        这题中树的构造与根节点的寻找其实在上一题《03-树1 树的同构》中已经做过了,详细可参考mooc陈越老师的数据结构课,这题关键在于树构造完成并且找到根节点之后,如何输出叶节点,而且是按照题目中的格式。哎,是不是很眼熟,就是层次遍历。

        层次遍历的过程其实mooc上那个课说的很清楚,我就不解释了,上代码!

//03-树2 List Leaves
#include<stdio.h>
#define Maxtree 10
#define Null -1
#define Tree int
#include<queue>
using namespace std;


struct Tree_Node{
    int number;
    Tree left;
    Tree right;
} T[Maxtree];

Tree BuildTree(struct Tree_Node T[], int length);

int main()
{
    Tree R;
    int i=0, N=0;
    scanf("%d", &N);
    R=BuildTree(T, N);
    queue <int> qu;
    qu.push(R);
    for(i=0;i<N;i++){
        if(T[R].left!=Null) qu.push(T[R].left);
        if(T[R].right!=Null) qu.push(T[R].right);
        qu.pop();
        R=qu.front();
        if(T[R].left==Null && T[R].right==Null){
            printf("%d", R);
            if(qu.size()>1) printf(" ");
        }
    }
        
    return 0;
}

Tree BuildTree(struct Tree_Node T[], int length)
{
    int i=0;
    Tree root=Null;
    char cl, cr;
    int check[length];
    for( i = 0; i < length; i++ ) check[i] = 0;
    for(i=0;i<length;i++){
        scanf("%c %c %c", &T[i].number, &cl, &cr);
        if(cl!='-'){
            T[i].left=cl-'0';
            check[T[i].left]=1;
        }
        else T[i].left=Null;
        if(cr!='-'){
            T[i].right=cr-'0';
            check[T[i].right]=1;
        }
        else T[i].right=Null;
    }
    for(i=0;i<length;i++){
        if(!check[i]) {
            root=i;
            break;
        }
    }
    return root;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值