1076 Forwards on Weibo (30 分)------C语言

Weibo is known as the Chinese version of Twitter. One user on Weibo may have many followers, and may follow many other users as well. Hence a social network is formed with followers relations. When a user makes a post on Weibo, all his/her followers can view and forward his/her post, which can then be forwarded again by their followers. Now given a social network, you are supposed to calculate the maximum potential amount of forwards for any specific user, assuming that only L levels of indirect followers are counted.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers: N (≤1000), the number of users; and L (≤6), the number of levels of indirect followers that are counted. Hence it is assumed that all the users are numbered from 1 to N. Then N lines follow, each in the format:

M[i] user_list[i]

where M[i] (≤100) is the total number of people that user[i] follows; and user_list[i] is a list of the M[i] users that followed by user[i]. It is guaranteed that no one can follow oneself. All the numbers are separated by a space.

Then finally a positive K is given, followed by K UserID's for query.

Output Specification:

For each UserID, you are supposed to print in one line the maximum potential amount of forwards this user can trigger, assuming that everyone who can view the initial post will forward it once, and that only L levels of indirect followers are counted.

Sample Input:

7 3
3 2 3 4
0
2 5 6
2 3 1
2 3 4
1 4
1 5
2 2 6

结尾无空行

Sample Output:

4
5

        这题只要会了六度空间,那就没问题了。

        核心的BFS算法和六度空间的一模一样。具体可以看我之前关于六度空间那道题的文章。代码我也贴上了,但是就不写解释了。

int BFS(PtrList G[], int visit[], int v)
{
    queue <int> qu;
    qu.push(v);
    int temp=0, tail=0, last=v, cnt=0, level=0;
    visit[v]=1;
    while(!qu.empty()){
        temp = qu.front();
        qu.pop();
        PtrList q = G[temp]->Next;
        while(q){
            if(visit[q->number]==0){
                qu.push(q->number);
                cnt++;
                visit[q->number]=1;
                tail=q->number;
            }
            q=q->Next;
        }
        if(temp==last){
            level++;
            last=tail;

        }
        if(level==L) break;
    }
    return cnt;
}

        然后需要稍微注意一下的就是,六度空间那道题是无向图,这题是有向图,因为只有粉丝能看见博主的文章,博主是看不见粉丝的文章的。

        也就是测试用例的第二行代码3 2 3 4,是代表了有2、3、4三个用户关注了博主1,可以看见1的文章,但是1看不见2、3、4的。所以构建邻接链表的时候,2、3、4号都要连上值为1的结点,但1不连2、3、4。

void InsertNode(int i, int n, PtrList p[])
{
    for(int k=0;k<n;k++){
        int Data;
        scanf("%d", &Data);
        PtrList node = (PtrList) malloc (sizeof(struct ListNode));
        node->Next=NULL;
        node->number=i;
        p[Data]->Next=node;
        p[Data]=node;

    }
}

注意到这个,这题就完成了。

//1076 Forwards on Weibo (30 分)
#include<stdio.h>
#include<stdlib.h>
#include<queue>
using namespace std;

int N, L;
struct ListNode{
    int number;
    struct ListNode* Next;
};
typedef struct ListNode* PtrList;

void Initialize(PtrList G[], PtrList p[], int visit[]);
void CreatList(PtrList p[]);
void InsertNode(int i, int n, PtrList p[]);
int BFS(PtrList G[], int visit[], int v);
void Reset(int visit[]);

int main()
{
    scanf("%d%d", &N, &L);
    int i=0, visit[N+1];
    PtrList G[N+1], p[N+1];
    Initialize(G, p, visit);
    CreatList(p);       //注意是个有向图 
    
    int K=0;
    scanf("%d", &K);
    int check[K];
    for(i=0;i<K;i++){
        scanf("%d", &check[i]);
    }
    
    for(i=0;i<K;i++){
        int cnt = BFS(G, visit, check[i]);
        Reset(visit);
        printf("%d", cnt);
        if(i!=K-1) printf("\n");
    }
}

void Initialize(PtrList G[], PtrList p[], int visit[])
{
    for(int i=1;i<=N;i++){
        PtrList head = (PtrList) malloc (sizeof(struct ListNode));
        head->Next=NULL;
        head->number=0;
        G[i]=head;
        p[i]=G[i];
        visit[i]=0;
    }
}

void CreatList(PtrList p[])
{
    for(int i=1;i<=N;i++){
        int n=0;
        scanf("%d", &n);
        InsertNode(i, n, p);
    }
}

void InsertNode(int i, int n, PtrList p[])
{
    for(int k=0;k<n;k++){
        int Data;
        scanf("%d", &Data);
        PtrList node = (PtrList) malloc (sizeof(struct ListNode));
        node->Next=NULL;
        node->number=i;
        p[Data]->Next=node;
        p[Data]=node;
    }
}

int BFS(PtrList G[], int visit[], int v)
{
    queue <int> qu;
    qu.push(v);
    int temp=0, tail=0, last=v, cnt=0, level=0;
    visit[v]=1;
    while(!qu.empty()){
        temp = qu.front();
        qu.pop();
        PtrList q = G[temp]->Next;
        while(q){
            if(visit[q->number]==0){
                qu.push(q->number);
                cnt++;
                visit[q->number]=1;
                tail=q->number;
            }
            q=q->Next;
        }
        if(temp==last){
            level++;
            last=tail;
        }
        if(level==L) break;
    }
    return cnt;
}

void Reset(int visit[])
{
    for(int i=1;i<=N;i++){
        visit[i]=0;
    }
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值