Let the Balloon Rise(题解)

ontest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges' favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color and find the result.

This year, they decide to leave this lovely job to you.

Input

Input contains multiple test cases. Each test case starts with a number N (0 < N <= 1000) -- the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case letters.

A test case with N = 0 terminates the input and this test case is not to be processed.

Output

For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case.

Sample Input

5
green
red
blue
red
red
3
pink
orange
pink
0

Sample Output

red
pink

思路:

主要是判断是不是这个颜色的方法,并不需要什么标记,需要的是比较长度,

然后再依次遍历,找到最大的部分直接输出就可以了!

代码:

#include<stdio.h>
#include<string.h>
#include<algorithm>
int main()
{
	int i,j,k,n;
	char ch[100010][16];
	int a[10001];
	for(i=0;i<10001;i++)
	{
		a[i]=0;
	}
	while(scanf("%d",&n)!=EOF)
	{
		if(n==0) break;
		if(n!=0){
			for(i=0;i<n;i++){
				scanf("%s",&ch[i]);
				for(j=0;j<i-1;j++){
					if(strcmp(ch[j],ch[i])==0) a[i]=a[i]+1;//比较取巧的是比较长度,如果一样,就加,从第一个开始比较 (它并不是给你逐个记录然后加,而是直接在最后出现这个元素的时候,找到最大的!)
				}
			}
		}
		int s=0;
		for(k=0;k<n;k++){
			if(a[k]>s) s=k;//找最大的,而不仅仅是找一个相对大的! 
		}
		printf("%s\n",ch[s]);
	}
 } 

  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值