课时3作业2

Description

读取一个整型数,字符,浮点数,分别到变量i,j,k中,然后将i,j,k直接相加并输出,小数点后保留两位小数,不用考虑输入的浮点数的小数部分超过了两位

Input

一个整型数,字符,浮点数

Output

i,j,k三个变量的求和值

Sample Input 1

10 a 98.3

Sample Output 1

205.30

#include <bits/stdc++.h>
using namespace std;
typedef long long LL;
typedef pair<int, int> PII;
const int N = 1e5 + 10;
int a[N];

void solve() {
    int i;
    char j;
    double k;
    double res = 0;
    cin >> i >> j >> k;
//    cout << i << j << k << '\n';
    res = i * 1.0 + (int)j * 1.0 + k;
    printf("%.2lf\n", res);
}

int main() {
    ios::sync_with_stdio(false);
    cin.tie(0); cout.tie(0);
    int _ = 1;
//    cin >> _;
    while (_ -- ) {
        solve();
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值