课时5作业1

Description

输入N个数(N小于等于100),输出数字2的出现次数;
解题提示:
整型数组读取5个整型数的方法如下:

int a[100];
for(int i=0;i<5;i++)
{
	scanf("%d",&a[i]);
}

Input

输入的格式是两行

第一行输入要输的元素个数,比如5

第二行输入 1 2 2 3 2,那么输出结果为3,因为2出现了3次

Output

统计数字2出现的次数

Sample Input 1

5
1 2 2 3 2

Sample Output 1

3

#include <bits/stdc++.h>
using namespace std;
typedef long long LL;
typedef pair<int, int> PII;
const int N = 1e5 + 10;
int a[N];

void solve() {
    int n;
    cin >> n;
    int x, cnt = 0;
    for (int i = 0; i < n; i ++ ) {
        cin >> x;
        if (x == 2) {
            cnt ++ ;
        }
    }
    cout << cnt << "\n";
}

int main() {
    ios::sync_with_stdio(false);
    cin.tie(0); cout.tie(0);
    int _ = 1;
//    cin >> _;
    while (_ -- ) {
        solve();
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值