#有空格字符串用char,读入用gets()
##例题hdu1062
Problem Description
Ignatius likes to write words in reverse way. Given a single line of text which is written by Ignatius, you should reverse all the words and then output them.
Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single line with several words. There will be at most 1000 characters in a line.
Output
For each test case, you should output the text which is processed.
Sample Input
3 olleh !dlrow
m’I morf .udh
I ekil .mca
Sample Output
hello world!
I’m from hdu.
I like acm.
####代码
#include<iostream>
#include<algorithm>
#include<cstring>
#include<stack>
using namespace std;
char a[1005];//对于有空格的情况,就用char
int main()
{
int t;
cin>>t;
getchar();//吞掉换行
while(t--)
{
gets(a);//可输入空格
int len=strlen(a);
for(int i=0;i<len;i++)
{
int x=i;
while(a[i]!=' '&&a[i]!='\0')i++;
int y=i-1;
for(int j=y;j>=x;j--){
cout<<a[j];
}
if(a[i]==' ')cout<<" ";
}
cout<<endl;
}
return 0;
}