迷宫问题
时间限制: 1Sec 内存限制: 32MB 提交: 3085 解决: 722
题目描述
小明置身于一个迷宫,请你帮小明找出从起点到终点的最短路程。
小明只能向上下左右四个方向移动。
输入
输入包含多组测试数据。输入的第一行是一个整数T,表示有T组测试数据。
每组输入的第一行是两个整数N和M(1<=N,M<=100)。
接下来N行,每行输入M个字符,每个字符表示迷宫中的一个小方格。
字符的含义如下:
‘S’:起点
‘E’:终点
‘-’:空地,可以通过
‘#’:障碍,无法通过
输入数据保证有且仅有一个起点和终点。
输出
对于每组输入,输出从起点到终点的最短路程,如果不存在从起点到终点的路,则输出-1。
样例输入复制
1 5 5 S-### ----- ##--- E#--- ---##
样例输出复制
9
思路:先在bfs函数中输入起点S的x,y,并将其换为‘#’。
设队列q记录可以走的点,只要q不为空,就一直进入循环。然后分为上下左右,4个方向,用point记录下一个方向的点,若可以走则,路程ans+1且push进q中。然后还要将走过的点换为'#',防止再走一次。
如果到了'E',则返回begin.ans+1.
每一次循环之后,要q.pop(),更换起始点位置。
最后当所有可走点都走过一遍后,q为空,退出循环,则返回-1
#include<iostream>
#include<algorithm>
#include<cstring>
#include<queue>
using namespace std;
int n, m;
struct DataType {
int x, y, ans;
};
char p[105][105];
int bfs(int x0,int y0)
{
queue<DataType> q;
DataType begin = { x0,y0,0 };//初始步数为 0
DataType point;
q.push(begin);//入口点进队列
p[x0][y0]='#';
while (!q.empty())
{
begin = q.front();
int x = begin.x;
int y = begin.y;
if (x + 1 <= n && p[x + 1][y] != '#')
{
if (p[x + 1][y] == '-')
{
point = { x+1,y,begin.ans+1 };
q.push(point);
p[x + 1][y] = '#';
}
else if (p[x + 1][y] == 'E')
{
point = { x + 1,y,begin.ans + 1 };
return point.ans ;
}
}
if (y + 1 <= m && p[x][y+1] != '#')
{
if (p[x][y+1] == '-')
{
point = { x,y+1,begin.ans + 1 };
q.push(point);
p[x][y+1] = '#';
}
else if (p[x][y+1] == 'E')
{
point = { x ,y + 1,begin.ans + 1 };
return point.ans;
}
}
if (x - 1 > 0 && p[x - 1][y] != '#')
{
if (p[x - 1][y] == '-')
{
point = { x - 1,y,begin.ans + 1 };
q.push(point);
p[x - 1][y] = '#';
}
else if (p[x - 1][y] == 'E')
{
point = { x - 1,y,begin.ans + 1 };
return point.ans;
}
}
if (y-1>0&&p[x][y-1] != '#')
{
if (p[x][y-1] == '-')
{
point = { x ,y - 1,begin.ans + 1 };
q.push(point);
p[x][y-1] = '#';
}
else if (p[x][y-1] == 'E')
{
point = { x ,y - 1,begin.ans + 1 };
return point.ans;
}
}
q.pop();
}
return -1;
}
int main()
{
int t;
cin >> t;
while (t--)
{
int si = 0, sj = 0;
cin >> n >> m;
for (int i = 1; i <= n; i++)
{
for (int j = 1; j <= m; j++)
{
cin >> p[i][j];
if (p[i][j] == 'S')
{
si = i, sj = j;
}
}
}
cout << bfs(si,sj) << endl;
}
return 0;
system("pause");
}